summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-17 05:00:33 +0100
committerSam James <sam@gentoo.org>2021-07-17 05:07:21 +0100
commit6f4d7fdd355ed60505190d989f2fd8e35eb9f182 (patch)
treea1c1a4128ef2bf99cb663662142955e7ba3b668d /dev-util/diffoscope
parentdev-lang/ruby: Stabilize 2.6.8 arm, #801061 (diff)
downloadgentoo-6f4d7fdd355ed60505190d989f2fd8e35eb9f182.tar.gz
gentoo-6f4d7fdd355ed60505190d989f2fd8e35eb9f182.tar.bz2
gentoo-6f4d7fdd355ed60505190d989f2fd8e35eb9f182.zip
dev-util/diffoscope: add 178
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest1
-rw-r--r--dev-util/diffoscope/diffoscope-178.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index b1ad171107cd..00f2659e4e76 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1 +1,2 @@
DIST diffoscope-177.tar.gz 1590984 BLAKE2B 94daf9528c8fd0ad6ed89bdbee7b21352bf33dcef2ae7e526ea3b1036d92b6fecefcb0da46b7eedf7af1c8bd7995e73b8f0a5104c02f4db534f7bcc465c803aa SHA512 674a5cc364927437a79420b0965eb6958bd09df58a1238ea4d953bb2bc0fbdde75e42817370dd3cdab0bcc59551e1cff70db72298087af551d5dfaee57995811
+DIST diffoscope-178.tar.gz 1600094 BLAKE2B b40e45748be56e49736a826decfb3a8c3ebd91983755719f2665733ceb6ec4e860265c33b5a3c15bc501abe4efdbecbdf177431bbbc79f1ad758c7deef83e1ae SHA512 706c95f5c04cfe081fed7e3e5ed73579949c948b15eaf0f984fc7d406b74007859f7946c44e4ca13e1210b105ed65ea68fd1f03452a50f161ed27f996f4f2540
diff --git a/dev-util/diffoscope/diffoscope-178.ebuild b/dev-util/diffoscope/diffoscope-178.ebuild
new file mode 100644
index 000000000000..b89f0d3a344a
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-178.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ )
+"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local exclude=(
+ # test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+
+ # needs triage
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+ )
+ epytest ${exclude[@]/#/--deselect }
+}