summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-08 06:11:44 +0000
committerSam James <sam@gentoo.org>2022-01-08 06:11:50 +0000
commitd864b4f3448f6c157526701a4a9d21ffbcb31c65 (patch)
tree2a399bd65a296917834fd4bec7d786f5f2086c38 /dev-util/diffoscope
parentnet-analyzer/bwping: add 2.4 (diff)
downloadgentoo-d864b4f3448f6c157526701a4a9d21ffbcb31c65.tar.gz
gentoo-d864b4f3448f6c157526701a4a9d21ffbcb31c65.tar.bz2
gentoo-d864b4f3448f6c157526701a4a9d21ffbcb31c65.zip
dev-util/diffoscope: add 199
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest1
-rw-r--r--dev-util/diffoscope/diffoscope-199.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 2258303a3004..247c93b5c145 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,3 +1,4 @@
DIST diffoscope-190.tar.gz 2704083 BLAKE2B a2a0313f87fdb9c20b0dc696a1aea570857dd7005e0f69dc2dd139bca86a4b5711f98862b60f4d1a581bf3e0dfd38ef3be96991b96862584f289f1eb80415480 SHA512 646380d52730cf2efef57e3fa2995c7b2d5958d75597a59a24027bca1fc35c5b59dd96352faac9b7bd1d5bc053064f11760877651d52099f6b1ca0b3ad65d63c
DIST diffoscope-197.tar.gz 2705041 BLAKE2B 1d66462d3f1cdbba177d24d194ce14ae51274c6b60139e56724213a6b4fc0b41e6a71f9f2e250ecc7d6330186bf774470b2153801b375ffb63e8390c425e1073 SHA512 d8411ad166738b29caa28abbc10f21e0906b7b19bd5ab644db36c04b1f9c5af9f4cbdb31eb850da7249380a6774bde355f0e815f4d3cdd0df76570df9df7fd0a
DIST diffoscope-198.tar.gz 2705246 BLAKE2B c0a10fb81f320825e3112104c06adf3861b310c56fd355b6ab533b818a210b56881d7978644496ffd1f787ff98c92c851c8b21493e9c3b4897bb73c8a0c728d4 SHA512 b8620600bba8691650768879a248b10f8417c0aaa12c4f59063eb77210dc93b91a9e8b9f83bbe915932cbbb1f45ea6b8c49cb5ac62622a114fe9a411a6384277
+DIST diffoscope-199.tar.gz 2705444 BLAKE2B c17752a504cef75d1a9d6f1c0dfdb896abd1ce7dfd5a2494022d4a7b9e098822db80b52e3cd0d4367e28bcc9ad6316746d10cd82df2ac7c24c19d74b3ea0de5d SHA512 e4caa9d5d8d7f1671acecf2f6240cd587bbfd4087eb6e69021303ec3e7bfde15fbd409139b7658eeed64d75f05b3768f1a585640fcfee6bae63ff7d27227e4d0
diff --git a/dev-util/diffoscope/diffoscope-199.ebuild b/dev-util/diffoscope/diffoscope-199.ebuild
new file mode 100644
index 000000000000..ec72907f21dc
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-199.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+)
+
+distutils_enable_tests pytest