summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 14:00:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:21:31 +0100
commitc4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4 (patch)
tree8d94ae0c64562dd097c75075c2eae0c0cc4c6ebc /dev-util/diffuse/diffuse-0.4.8-r1.ebuild
parentdev-util/dbus-test-runner: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-c4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4.tar.gz
gentoo-c4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4.tar.bz2
gentoo-c4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4.zip
dev-util/diffuse: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/diffuse/diffuse-0.4.8-r1.ebuild')
-rw-r--r--dev-util/diffuse/diffuse-0.4.8-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/diffuse/diffuse-0.4.8-r1.ebuild b/dev-util/diffuse/diffuse-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..5a0d5a3968a4
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.4.8-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime python-single-r1
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygtk[${PYTHON_MULTI_USEDEP}]
+ ')"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ local i p
+
+ # linguas handling wrt #406433
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(for p in translations/*.po ; do echo ${p%.po} ; done) ; do
+ if ! has ${i##*/} ${LINGUAS} ; then
+ rm "${S}"/${i}.po || die
+ fi
+ done
+ fi
+
+ python_fix_shebang src/usr/bin/diffuse
+}
+
+src_install() {
+ "${PYTHON}" install.py \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --files-only \
+ --destdir="${D}" \
+ || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}