summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 14:00:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:21:31 +0100
commitc4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4 (patch)
tree8d94ae0c64562dd097c75075c2eae0c0cc4c6ebc /dev-util/diffuse/diffuse-0.5.0_alpha7-r1.ebuild
parentdev-util/dbus-test-runner: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-c4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4.tar.gz
gentoo-c4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4.tar.bz2
gentoo-c4caafb8fe9792ea140e499d6c4d9f6aa5cb07b4.zip
dev-util/diffuse: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/diffuse/diffuse-0.5.0_alpha7-r1.ebuild')
-rw-r--r--dev-util/diffuse/diffuse-0.5.0_alpha7-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/diffuse/diffuse-0.5.0_alpha7-r1.ebuild b/dev-util/diffuse/diffuse-0.5.0_alpha7-r1.ebuild
new file mode 100644
index 000000000000..1cb786be52c5
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.5.0_alpha7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PLOCALES="cs de es it ja ko pl pt ru sv th zh_CN zh_TW"
+inherit python-single-r1 l10n xdg-utils
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/ https://github.com/MightyCreak/diffuse/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP},cairo]
+ ')
+ x11-libs/gtk+:3[introspection]"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ default
+ l10n_find_plocales_changes translations '' '.po'
+
+ rm_locale() {
+ rm -f translations/${1}.po
+ rm -rf src/usr/share/man/${1}
+ rm -rf src/usr/share/gnome/help/${PN}/$1
+ rm -f src/usr/share/omf/${PN}/${PN}-$1.omf
+ }
+
+ l10n_for_each_disabled_locale_do rm_locale
+}
+
+src_install() {
+ "${PYTHON}" install.py \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --files-only \
+ --destdir="${D}" \
+ || die "Installation failed"
+ dodoc AUTHORS ChangeLog README.md
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}