summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/diffuse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/diffuse')
-rw-r--r--dev-util/diffuse/Manifest3
-rw-r--r--dev-util/diffuse/diffuse-0.4.6.ebuild46
-rw-r--r--dev-util/diffuse/diffuse-0.4.7-r1.ebuild58
-rw-r--r--dev-util/diffuse/diffuse-0.4.8.ebuild58
-rw-r--r--dev-util/diffuse/metadata.xml12
5 files changed, 177 insertions, 0 deletions
diff --git a/dev-util/diffuse/Manifest b/dev-util/diffuse/Manifest
new file mode 100644
index 000000000000..28193c7b0482
--- /dev/null
+++ b/dev-util/diffuse/Manifest
@@ -0,0 +1,3 @@
+DIST diffuse-0.4.6.tar.bz2 170246 SHA256 748922902573de316a4829f1ccc2cb6fab218b4aaf69a1a4aadba7fd8f8fd916 SHA512 ddde5e6c06ecaeb9b164de47590f22074e52d32a9969764466aa09a2a24925b6fa6aa3a098816c83d4fdef34ff1d2d88eab963a3bb8de3f403e40d797d497ae6 WHIRLPOOL cc8cc5e43cf1c098a4b92f8e33c7aeb48e82bbe9ad2bf7de833ec0c29b150938e4b10c90de19d142d771bd3720d686d9d3bb4e8521311d5f4f771e273c27edce
+DIST diffuse-0.4.7.tar.bz2 189257 SHA256 b0f56acbd246f4b9a692ef51aab167134ae6650423a68d8e5f4ff4c8938f39ac SHA512 3db665ec2f05d8fd8b30f391a53e75ae0ef271d3f35f0c89f20226bda296ca46e88491a741cd3bcaa1159b9d5d2581931362ca600176b6d599351f4a34f56e2f WHIRLPOOL 3a0c382ffcb598f0d3aba8c9e45914a83d41a9f946f6cf10aab73320fdf8f6b8cc4f5f84ad6c86ca61e2ed33d00faa50d3846a560ebd4b7e9588402eefa055d2
+DIST diffuse-0.4.8.tar.bz2 557966 SHA256 c1d3b79bba9352fcb9aa4003537d3fece248fb824781c5e21f3fcccafd42df2b SHA512 0c62976526804a328f1cc1775f842e9575fab50309cc964171af5ee89d8f303d4cbdf66a078ed64bb8826f5a57c2cc7fc59afc1ee87646ece340212d34f2514e WHIRLPOOL d1f044497103c6c429f9980fa759e3df019176359adf13bd71d07c030188aad7c297a2b202290ac7124beed3536172ba17aca18d1e7a4b535218e3dd2cb015d3
diff --git a/dev-util/diffuse/diffuse-0.4.6.ebuild b/dev-util/diffuse/diffuse-0.4.6.ebuild
new file mode 100644
index 000000000000..6c8868ac4652
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.4.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit fdo-mime python
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk"
+# file collision, bug #279018
+DEPEND="!sci-chemistry/tinker"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs 2 src/usr/bin/diffuse
+}
+
+src_install() {
+ "$(PYTHON)" install.py \
+ --prefix=/usr \
+ --files-only \
+ --destdir="${D}" \
+ || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/dev-util/diffuse/diffuse-0.4.7-r1.ebuild b/dev-util/diffuse/diffuse-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..f1ea525ddd8e
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.4.7-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime python-single-r1
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ local i p
+
+ # linguas handling wrt #406433
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(for p in translations/*.po ; do echo ${p%.po} ; done) ; do
+ if ! has ${i##*/} ${LINGUAS} ; then
+ rm "${S}"/${i}.po || die
+ fi
+ done
+ fi
+
+ python_fix_shebang src/usr/bin/diffuse
+}
+
+src_install() {
+ "${PYTHON}" install.py \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --files-only \
+ --destdir="${D}" \
+ || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/dev-util/diffuse/diffuse-0.4.8.ebuild b/dev-util/diffuse/diffuse-0.4.8.ebuild
new file mode 100644
index 000000000000..f1ea525ddd8e
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.4.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime python-single-r1
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ local i p
+
+ # linguas handling wrt #406433
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(for p in translations/*.po ; do echo ${p%.po} ; done) ; do
+ if ! has ${i##*/} ${LINGUAS} ; then
+ rm "${S}"/${i}.po || die
+ fi
+ done
+ fi
+
+ python_fix_shebang src/usr/bin/diffuse
+}
+
+src_install() {
+ "${PYTHON}" install.py \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --files-only \
+ --destdir="${D}" \
+ || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/dev-util/diffuse/metadata.xml b/dev-util/diffuse/metadata.xml
new file mode 100644
index 000000000000..744ec303222c
--- /dev/null
+++ b/dev-util/diffuse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>A graphical tool to compare and merge text files</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">diffuse</remote-id>
+ </upstream>
+</pkgmetadata>