summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-02-22 18:43:46 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-02-22 18:44:20 -0700
commit198a2ab7a9b5b4749c9ba74b4b2174044abf975e (patch)
tree165e6c640fac1148fd5dbc2403fc78fc26f1aeb5 /dev-util/doxy-coverage/doxy-coverage-151229.ebuild
parentdev-ml/zarith: fix bug 585026 (diff)
downloadgentoo-198a2ab7a9b5b4749c9ba74b4b2174044abf975e.tar.gz
gentoo-198a2ab7a9b5b4749c9ba74b4b2174044abf975e.tar.bz2
gentoo-198a2ab7a9b5b4749c9ba74b4b2174044abf975e.zip
dev-util/doxy-coverage: initial commit
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-util/doxy-coverage/doxy-coverage-151229.ebuild')
-rw-r--r--dev-util/doxy-coverage/doxy-coverage-151229.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/doxy-coverage/doxy-coverage-151229.ebuild b/dev-util/doxy-coverage/doxy-coverage-151229.ebuild
new file mode 100644
index 000000000000..3f7910be37fe
--- /dev/null
+++ b/dev-util/doxy-coverage/doxy-coverage-151229.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="29a0bbf43bfecb6872cdca0e4a11733954d25196"
+DESCRIPTION="Source Code Documentation Coverage Measurement"
+HOMEPAGE="https://github.com/alobbs/doxy-coverage"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ default
+ python_foreach_impl python_newexe "${PN}"{.py,}
+}