summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gmail.com>2016-05-19 19:08:39 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-20 00:25:30 +0800
commit2e83c20fd2f681dbaf1ec2adad93d32e6756610f (patch)
treeab33909f2cf60ad3fb7b3aef6e687c0856172f87 /dev-util/dput-ng/dput-ng-1.10.ebuild
parentdev-util/distro-info: initial ebuild version - 0.14 (diff)
downloadgentoo-2e83c20fd2f681dbaf1ec2adad93d32e6756610f.tar.gz
gentoo-2e83c20fd2f681dbaf1ec2adad93d32e6756610f.tar.bz2
gentoo-2e83c20fd2f681dbaf1ec2adad93d32e6756610f.zip
dev-util/dput-ng: initial ebuild version - 1.10
Package will be maintained by Yuri Konotopov <ykonotopov@gmail.com> via Proxy Maintainers Project. Closes: https://github.com/gentoo/gentoo/pull/1465 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-util/dput-ng/dput-ng-1.10.ebuild')
-rw-r--r--dev-util/dput-ng/dput-ng-1.10.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/dput-ng/dput-ng-1.10.ebuild b/dev-util/dput-ng/dput-ng-1.10.ebuild
new file mode 100644
index 000000000000..cdfed677039a
--- /dev/null
+++ b/dev-util/dput-ng/dput-ng-1.10.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Next generation Debian package upload tool"
+HOMEPAGE="https://people.debian.org/~paultag/dput-ng/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-debian[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-util/distro-info[python,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/python-debian[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${PN/-/}"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ mkdir man || die
+ for file in docs/man/*.man; do
+ a2x --doctype manpage --format manpage -D man \
+ "${file}" || die
+ done
+}
+
+src_install() {
+ local DPUT_BINARIES=( dcut dirt dput )
+ local DPUT_ETC=( metas profiles )
+ local DPUT_SHARE=(
+ codenames
+ commands
+ hooks
+ interfaces
+ schemas
+ uploaders
+ )
+
+ distutils-r1_src_install
+
+ for binary in ${DPUT_BINARIES[@]}; do
+ dobin bin/"${binary}"
+ done
+ python_fix_shebang "${D}"/usr/bin
+
+ insinto /etc/dput.d
+ for dir in ${DPUT_ETC[@]}; do
+ doins -r skel/"${dir}"
+ done
+
+ insinto /usr/share/"${PN}"
+ for dir in ${DPUT_SHARE[@]}; do
+ doins -r skel/"${dir}"
+ done
+
+ insinto /usr/share/man/man5
+ doins man/dput.cf.5
+ rm man/dput.cf.5 || die
+
+ for file in man/*; do
+ doman "${file}"
+ done
+
+ newbashcomp debian/"${PN}".bash-completion dput
+}
+
+python_test() {
+ # test_configs.py failing
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824652
+ nosetests || die "Tests failed under ${EPYTHON}"
+}