summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-05 02:26:21 +0100
committerSam James <sam@gentoo.org>2021-08-05 02:26:21 +0100
commit72c1def52827d5becfb23b3312754d26468c8e0e (patch)
tree4ee7e8d45776d141a401e1595c30311b30a659b5 /dev-util/duma
parentsci-libs/cdd+: update EAPI 5 -> 7, fix build with GCC 11 (diff)
downloadgentoo-72c1def52827d5becfb23b3312754d26468c8e0e.tar.gz
gentoo-72c1def52827d5becfb23b3312754d26468c8e0e.tar.bz2
gentoo-72c1def52827d5becfb23b3312754d26468c8e0e.zip
dev-util/duma: workaround GCC 11 build failure for now
Going with this given a new release is coming which fixes the issue properly anyhow. Closes: https://bugs.gentoo.org/789708 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/duma')
-rw-r--r--dev-util/duma/duma-2.5.15-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-util/duma/duma-2.5.15-r2.ebuild b/dev-util/duma/duma-2.5.15-r2.ebuild
index a3293c92f738..92aff79a7b79 100644
--- a/dev-util/duma/duma-2.5.15-r2.ebuild
+++ b/dev-util/duma/duma-2.5.15-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs versionator
+inherit flag-o-matic toolchain-funcs versionator
MY_P=${PN}_$(replace_all_version_separators '_')
@@ -28,6 +28,9 @@ src_configure() {
export CFLAGS="-O0 -Wall -Wextra -U_FORTIFY_SOURCE"
tc-export AR CC CXX LD RANLIB
+ # bug #789708
+ append-cxxflags -std=c++14
+
case "${CHOST}" in
*-linux-gnu)
OS=linux;;