summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-12-16 21:55:20 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-12-16 22:03:10 +0100
commit4580d02134f001d96c73d15ac51f6abc4d0f50dd (patch)
treea258345cb39fc3dfa469e41aa11fddb7aecc6f54 /dev-util/dwarves/dwarves-1.16-r1.ebuild
parentapp-emacs/websocket: Remove old. (diff)
downloadgentoo-4580d02134f001d96c73d15ac51f6abc4d0f50dd.tar.gz
gentoo-4580d02134f001d96c73d15ac51f6abc4d0f50dd.tar.bz2
gentoo-4580d02134f001d96c73d15ac51f6abc4d0f50dd.zip
dev-util/dwarves: revbump to -r1 to use newer elfutils
Currently dwarves is holding back elfutils in the tree, due to a library reorganization, so we patch dwarves in order to support the latest elfutils. Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'dev-util/dwarves/dwarves-1.16-r1.ebuild')
-rw-r--r--dev-util/dwarves/dwarves-1.16-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/dwarves/dwarves-1.16-r1.ebuild b/dev-util/dwarves/dwarves-1.16-r1.ebuild
new file mode 100644
index 000000000000..c58ef0fd660d
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.16-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+ S=${WORKDIR}
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+ "${FILESDIR}"/${PN}-1.16-no-libebl.patch
+)
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+}