summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-12-19 20:36:48 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-12-23 22:44:31 +0100
commit72444aa1160c966ad74733af41b8d60e9cf3bcc4 (patch)
treebd36b9c1a5aa5f8ebe19159370b155b513bb0953 /dev-util/dwdiff/dwdiff-2.1.2.ebuild
parentapp-vim/frawor: mark stable for amd64+x86. (diff)
downloadgentoo-72444aa1160c966ad74733af41b8d60e9cf3bcc4.tar.gz
gentoo-72444aa1160c966ad74733af41b8d60e9cf3bcc4.tar.bz2
gentoo-72444aa1160c966ad74733af41b8d60e9cf3bcc4.zip
dev-util/dwdiff: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util/dwdiff/dwdiff-2.1.2.ebuild')
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/dwdiff/dwdiff-2.1.2.ebuild b/dev-util/dwdiff/dwdiff-2.1.2.ebuild
new file mode 100644
index 000000000000..0ed5a821f25a
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="diff-like program operating at word level instead of line level"
+HOMEPAGE="https://os.ghalkes.nl/dwdiff.html"
+SRC_URI="https://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+CDEPEND="dev-libs/icu:="
+
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/diffutils"
+
+DEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}