summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-11-10 11:00:23 -0800
committerZac Medico <zmedico@gentoo.org>2019-11-10 11:02:21 -0800
commit9dd2601f275c9172deeddead235f416efc94bc86 (patch)
treee95b837f3e0d091d1c2177f465defd5150d5651f /dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild
parentmedia-libs/libchamplain: Bump to 0.12.20 (diff)
downloadgentoo-9dd2601f275c9172deeddead235f416efc94bc86.tar.gz
gentoo-9dd2601f275c9172deeddead235f416efc94bc86.tar.bz2
gentoo-9dd2601f275c9172deeddead235f416efc94bc86.zip
dev-util/editorconfig-geany: Bump to version 0.2
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild')
-rw-r--r--dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild b/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild
new file mode 100644
index 000000000000..3e1268e041e6
--- /dev/null
+++ b/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="EditorConfig plugin for Geany"
+HOMEPAGE="https://github.com/editorconfig/editorconfig-geany/"
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/editorconfig/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+CDEPEND="app-text/editorconfig-core-c:="
+DEPEND="${CDEPEND}
+ dev-util/geany"
+RDEPEND="${CDEPEND}"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT#v}
+
+src_prepare() {
+ eapply_user
+ sed -e "s|^\\(EDITORCONFIG_PREFIX =\\).*|\\1 ${EPREFIX}/usr|" \
+ -e "s|^\\(CFLAGS =\\).*|\\1 -fPIC $("$(tc-getPKG_CONFIG)" --cflags geany geany) ${CFLAGS}|" \
+ -e "s|^\\(LDFLAGS =.*\\)|\\1 ${LDFLAGS}|" \
+ -e "s|\`pkg-config[^\`]*\`||" \
+ -i Makefile || die
+}
+
+src_install() {
+ exeinto "$("$(tc-getPKG_CONFIG)" --variable=libdir geany)/geany"
+ doexe ${PN}.so
+ dodoc README.md
+}