summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>2018-07-15 17:30:30 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-17 17:24:45 +0100
commit2ed2865794e0a21572eca83543082fcacd3117ba (patch)
tree02ecb77cabb63f3ece31736732c9a0bb6c260513 /dev-util/envman/envman-1.2.0.ebuild
parentdev-python/h11: Introducing new package (diff)
downloadgentoo-2ed2865794e0a21572eca83543082fcacd3117ba.tar.gz
gentoo-2ed2865794e0a21572eca83543082fcacd3117ba.tar.bz2
gentoo-2ed2865794e0a21572eca83543082fcacd3117ba.zip
dev-util/envman: new ebuild, version 1.2.0
Closes: https://github.com/gentoo/gentoo/pull/9236 Closes: https://bugs.gentoo.org/661248 Closes: https://bugs.gentoo.org/657710
Diffstat (limited to 'dev-util/envman/envman-1.2.0.ebuild')
-rw-r--r--dev-util/envman/envman-1.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/envman/envman-1.2.0.ebuild b/dev-util/envman/envman-1.2.0.ebuild
new file mode 100644
index 000000000000..6713bc5a103a
--- /dev/null
+++ b/dev-util/envman/envman-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Environment variable manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/envman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/envman || die "Couldn't compile envman"
+}
+
+src_test() {
+ GOPATH="${WORKDIR}" go test ./... || die "Tests failed"
+}
+
+src_install() {
+ dobin bin/envman
+ dodoc README.md
+}