summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/febootstrap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/febootstrap')
-rw-r--r--dev-util/febootstrap/Manifest1
-rw-r--r--dev-util/febootstrap/febootstrap-2.11.ebuild38
-rw-r--r--dev-util/febootstrap/files/remove_all-static.patch12
-rw-r--r--dev-util/febootstrap/metadata.xml12
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/febootstrap/Manifest b/dev-util/febootstrap/Manifest
new file mode 100644
index 000000000000..b86ee2441f0c
--- /dev/null
+++ b/dev-util/febootstrap/Manifest
@@ -0,0 +1 @@
+DIST febootstrap-2.11.tar.gz 585966 SHA256 e99d0411702eb619127cc6e2f79a5f4d2fec3d0524e46069738c5ed5b5dc69f4 SHA512 243171e779449f7f25c422842aaef3d5eff5931397530a9b6b1a168ef0fd723ebc4f38846b7699ce7271a715f266033ad2a033ef0aca1b4811d9c7e68929e4ee WHIRLPOOL dbb93f3d502f68b197175cd23d7c2e4faf05a8041efdfb93fbbb9635bdb07e0dd4a39a55fc8b7c1c99827f34505582e08586b10a8e625e0e6b63028625812b01
diff --git a/dev-util/febootstrap/febootstrap-2.11.ebuild b/dev-util/febootstrap/febootstrap-2.11.ebuild
new file mode 100644
index 000000000000..dc1da839142f
--- /dev/null
+++ b/dev-util/febootstrap/febootstrap-2.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Fedora bootstrap scripts"
+HOMEPAGE="http://people.redhat.com/~rjones/febootstrap/"
+SRC_URI="http://people.redhat.com/~rjones/febootstrap/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/fakeroot-1.11
+ >=sys-apps/fakechroot-2.9
+ dev-lang/perl
+ >=sys-apps/yum-3.2.21
+ sys-fs/e2fsprogs
+ sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+QA_EXECSTACK="usr/bin/febootstrap-supermin-helper"
+
+src_prepare() {
+ # https://lists.gnu.org/archive/html/grub-devel/2012-07/msg00051.html
+ sed -i -e '/gets is a security/d' lib/stdio.in.h
+ epatch "${FILESDIR}"/remove_all-static.patch
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO README examples/*.sh || die
+}
diff --git a/dev-util/febootstrap/files/remove_all-static.patch b/dev-util/febootstrap/files/remove_all-static.patch
new file mode 100644
index 000000000000..4f0f16e79b92
--- /dev/null
+++ b/dev-util/febootstrap/files/remove_all-static.patch
@@ -0,0 +1,12 @@
+diff --git a/helper/Makefile.am b/helper/Makefile.am
+--- a/helper/Makefile.am
++++ b/helper/Makefile.am
+@@ -40,7 +40,7 @@
+ noinst_PROGRAMS = init
+ init_SOURCES = init.c
+ init_CFLAGS = -static
+-init_LDFLAGS = -all-static
++init_LDFLAGS = -static
+
+ # http://www.doof.me.uk/2010/05/07/cute-objcopy-hack/
+ ELF_DEFAULT_ARCH = $(shell $(srcdir)/elf-default-arch | gawk '{ print $$1 }')
diff --git a/dev-util/febootstrap/metadata.xml b/dev-util/febootstrap/metadata.xml
new file mode 100644
index 000000000000..d62d48a3f6df
--- /dev/null
+++ b/dev-util/febootstrap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+</maintainer>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+</pkgmetadata>