summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-21 13:38:35 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-21 13:38:35 +0100
commitb1a257f4a5459b0962dc72867aee2c39a893a6fb (patch)
tree229ff7118866b58c7e5ff4bbd2595bf0f6816749 /dev-util/fhist/fhist-1.21.ebuild
parentdev-python/pyamf: Drop versions vulnerable for CVE-2015-8549 (diff)
downloadgentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.tar.gz
gentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.tar.bz2
gentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.zip
dev-util/fhist: Version Bump and fix build failure with gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568962 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-util/fhist/fhist-1.21.ebuild')
-rw-r--r--dev-util/fhist/fhist-1.21.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/fhist/fhist-1.21.ebuild b/dev-util/fhist/fhist-1.21.ebuild
new file mode 100644
index 000000000000..d3a2b031b687
--- /dev/null
+++ b/dev-util/fhist/fhist-1.21.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.D001.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libexplain
+ sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ test? ( app-arch/sharutils )"
+
+src_prepare() {
+ MAKEOPTS+=" -j1"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ append-cflags -fgnu89-inline
+}