summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-24 09:13:35 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-24 20:52:06 +0200
commitc2d59cc2223b58385f3f200aa5d28e7475f7157c (patch)
treee681da6e67a055c63c4640fa9fa7bcac8467b297 /dev-util/gcovr/gcovr-4.2.ebuild
parentdev-python/requests_download-0.1.2: Add py39 and py310 (diff)
downloadgentoo-c2d59cc2223b58385f3f200aa5d28e7475f7157c.tar.gz
gentoo-c2d59cc2223b58385f3f200aa5d28e7475f7157c.tar.bz2
gentoo-c2d59cc2223b58385f3f200aa5d28e7475f7157c.zip
dev-util/gcovr: bump to python 3.9, enable partial tests
- tested by merging and running on various examples - enabled partial tests, which is better than nothing the failing tests fail because of old GCC version format Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/gcovr/gcovr-4.2.ebuild')
-rw-r--r--dev-util/gcovr/gcovr-4.2.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/dev-util/gcovr/gcovr-4.2.ebuild b/dev-util/gcovr/gcovr-4.2.ebuild
index 580ac995f399..cd46ba9fd4a5 100644
--- a/dev-util/gcovr/gcovr-4.2.ebuild
+++ b/dev-util/gcovr/gcovr-4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -15,23 +15,15 @@ SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/PyUtilib[${PYTHON_USEDEP}]
- )
+BDEPEND="
+ test? ( dev-python/PyUtilib[${PYTHON_USEDEP}] )
"
-# tests fail on gcc newer than 5.8
-# https://github.com/gcovr/gcovr/issues/206
-RESTRICT="test"
-
distutils_enable_tests pytest
python_test() {
@@ -40,5 +32,11 @@ python_test() {
local -x PATH="${TEST_DIR}/scripts:${PATH}" \
PYTHONPATH="${TEST_DIR}/lib"
- pytest -vv gcovr || die "Tests fail with ${EPYTHON}"
+ local deselect=(
+ # those tests fail on gcc newer than 5.8
+ # https://github.com/gcovr/gcovr/issues/206
+ gcovr/tests/test_gcovr.py
+ )
+
+ epytest gcovr ${deselect[@]/#/--deselect }
}