summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-20 08:39:46 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-20 09:11:00 +0300
commitcd02b03cb5ac359f7a0f8e2a1bf37632a26f0e08 (patch)
treea98e1ef8b6534349d7f64317bf51c4304e235664 /dev-util/gdbus-codegen
parentdev-util/glib-utils: Build time utilities for glib using projects (diff)
downloadgentoo-cd02b03cb5ac359f7a0f8e2a1bf37632a26f0e08.tar.gz
gentoo-cd02b03cb5ac359f7a0f8e2a1bf37632a26f0e08.tar.bz2
gentoo-cd02b03cb5ac359f7a0f8e2a1bf37632a26f0e08.zip
dev-util/gdbus-codegen: bump to 2.56.2
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-util/gdbus-codegen')
-rw-r--r--dev-util/gdbus-codegen/Manifest1
-rw-r--r--dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch54
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.56.2.ebuild46
3 files changed, 101 insertions, 0 deletions
diff --git a/dev-util/gdbus-codegen/Manifest b/dev-util/gdbus-codegen/Manifest
index a90fdd900713..0b64672ba5de 100644
--- a/dev-util/gdbus-codegen/Manifest
+++ b/dev-util/gdbus-codegen/Manifest
@@ -1,2 +1,3 @@
DIST glib-2.52.3.tar.xz 7679972 BLAKE2B 8d9f6b714571bd04ab9717fbf9ded8556664e43dcdb7dd59436b8b7f1a8a5cdf98e9ce60ca1ead941af1d57688044fefb6c749fa735084622a3482b058864ff6 SHA512 a068f2519cfb82de8d4b7f004e7c1f15e841cad4046430a83b02b359d011e0c4077cdff447a1687ed7c68f1a11b4cf66b9ed9fc23ab5f0c7c6be84eb0ddc3017
DIST glib-2.54.3.tar.xz 7836536 BLAKE2B 140e7cf09a41b72a5b22e5b87e9674cbfdfe1b82f3cf5f0fd3ecb2ed6b1f62a90f8b4c0bc2f655e297f91394f771f6ecad210357e31f104ee49ca178be6b9d76 SHA512 23eb4458684624f80c17aa784eab42a38eec87bb5979fcfe56f0bc63b5c7bcf8251a0d4ea916fe2c8109ff5b14a4b60c6260755d079ff984c0d8e6a2871d307d
+DIST glib-2.56.2.tar.xz 8041756 BLAKE2B 1af5bb37378856e959602bcb9299266bba46b990839c923f6b9881624aed306af0779005281b3e3a46b5994c54812edc86aade9cb782c596fd63b6fd91baba51 SHA512 8201ea82d3613d2e879284abe01520b766da30957c5a1a22f3e6019b0cce6bf95d25beae78867b6a133401c4165153c0c92974dd459ab12f9e0e9dd0c95df5d4
diff --git a/dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch b/dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch
new file mode 100644
index 000000000000..30f0d7dcc7c0
--- /dev/null
+++ b/dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch
@@ -0,0 +1,54 @@
+From 9eaaa76e2e36e46a43dbd419724696fd7ff8ea64 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Sat, 14 Apr 2018 09:55:22 +0200
+Subject: [PATCH 1/2] gdbus-codegen-2.54.3-sitedir.patch
+
+---
+ gio/gdbus-2.0/codegen/gdbus-codegen.in | 28 --------------------------
+ 1 file changed, 28 deletions(-)
+
+diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in
+index 67d367543..190afa28f 100755
+--- a/gdbus-codegen.in
++++ b/gdbus-codegen.in
+@@ -20,36 +20,8 @@
+ # Author: David Zeuthen <davidz@redhat.com>
+
+
+-import os
+ import sys
+
+-srcdir = os.getenv('UNINSTALLED_GLIB_SRCDIR', None)
+-filedir = os.path.dirname(__file__)
+-
+-if srcdir is not None:
+- path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
+-elif os.path.basename(filedir) == 'bin':
+- # Make the prefix containing gdbus-codegen 'relocatable' at runtime by
+- # adding /some/prefix/bin/../share/glib-2.0 to the python path
+- path = os.path.join(filedir, '..', 'share', 'glib-2.0')
+-else:
+- # Assume that the modules we need are in the current directory and add the
+- # parent directory to the python path.
+- path = os.path.join(filedir, '..')
+-
+-# Canonicalize, then do further testing
+-path = os.path.abspath(path)
+-
+-# If the above path detection failed, use the hard-coded datadir. This can
+-# happen when, for instance, bindir and datadir are not in the same prefix or
+-# on Windows where we cannot make any guarantees about the directory structure.
+-#
+-# In these cases our installation cannot be relocatable, but at least we should
+-# be able to find the codegen module.
+-if not os.path.isfile(os.path.join(path, 'codegen', 'codegen_main.py')):
+- path = os.path.join('@DATADIR@', 'glib-2.0')
+-
+-sys.path.insert(0, path)
+-from codegen import codegen_main
++from gdbus_codegen import codegen_main
+
+ sys.exit(codegen_main.codegen_main())
+--
+2.17.0
+
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.56.2.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.56.2.ebuild
new file mode 100644
index 000000000000..943c070c9b93
--- /dev/null
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.56.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="glib"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome.org distutils-r1
+
+DESCRIPTION="GDBus code and documentation generator"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+# To prevent circular dependencies with glib[test]
+PDEPEND=">=dev-libs/glib-${PV}:2"
+
+S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
+
+python_prepare_all() {
+ PATCHES=(
+ "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
+ )
+ distutils-r1_python_prepare_all
+
+ sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
+ cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
+ sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
+}
+
+src_test() {
+ einfo "Skipping tests. This package is tested by dev-libs/glib"
+ einfo "when merged with FEATURES=test"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all # no-op, but prevents QA warning
+ doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
+}