summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-18 13:54:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-18 13:54:48 -0500
commit303fd7efb5225dc07c74fa01e30b913493d6b0a4 (patch)
treeded5ea78f805d4e45103897497b38ccf4086ccd6 /dev-util/gertty/gertty-1.6.0-r1.ebuild
parentdev-python/xmlschema: x86 stable (bug #749534) (diff)
downloadgentoo-303fd7efb5225dc07c74fa01e30b913493d6b0a4.tar.gz
gentoo-303fd7efb5225dc07c74fa01e30b913493d6b0a4.tar.bz2
gentoo-303fd7efb5225dc07c74fa01e30b913493d6b0a4.zip
dev-util/gertty: add py38 and set DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/749882 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-util/gertty/gertty-1.6.0-r1.ebuild')
-rw-r--r--dev-util/gertty/gertty-1.6.0-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-util/gertty/gertty-1.6.0-r1.ebuild b/dev-util/gertty/gertty-1.6.0-r1.ebuild
index 74a745757acf..6dcac9474c90 100644
--- a/dev-util/gertty/gertty-1.6.0-r1.ebuild
+++ b/dev-util/gertty/gertty-1.6.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -21,12 +22,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
-CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
>=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
>=dev-python/GitPython-0.3.7[${PYTHON_USEDEP}]