summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2022-11-06 13:38:20 -0800
committerSteve Arnold <nerdboy@gentoo.org>2022-11-06 13:38:20 -0800
commit6ee71e373489854fc89ae1a19ba709f36ef278cb (patch)
tree637e72bb41b463db98e23a56903e7033f5d2f3b0 /dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
parentapp-emulation/plus42: add 1.0.12 (diff)
downloadgentoo-6ee71e373489854fc89ae1a19ba709f36ef278cb.tar.gz
gentoo-6ee71e373489854fc89ae1a19ba709f36ef278cb.tar.bz2
gentoo-6ee71e373489854fc89ae1a19ba709f36ef278cb.zip
dev-util/gitchangelog: version bump to latest
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'dev-util/gitchangelog/gitchangelog-3.0.9.ebuild')
-rw-r--r--dev-util/gitchangelog/gitchangelog-3.0.9.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild b/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
deleted file mode 100644
index d2e9d691c1bb..000000000000
--- a/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTULS_USE_SETUPTOOLS="pyproject.toml"
-
-inherit distutils-r1
-
-DESCRIPTION="Creates a changelog from git log history"
-HOMEPAGE="https://github.com/sarnold/gitchangelog"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/sarnold/gitchangelog.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-BDEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/minimock[${PYTHON_USEDEP}] )
-"
-
-DEPEND="${PYTHON_DEPS}
- dev-python/pystache[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
-"
-
-RESTRICT="!test? ( test )"
-
-python_test() {
- "${EPYTHON}" -m nose -sx . || die "Testing failed with ${EPYTHON}"
-}