summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/glade/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/glade/files')
-rw-r--r--dev-util/glade/files/glade-3.14.1-doc-version.patch29
-rw-r--r--dev-util/glade/files/glade-3.18.1-underlinking.patch46
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/glade/files/glade-3.14.1-doc-version.patch b/dev-util/glade/files/glade-3.14.1-doc-version.patch
new file mode 100644
index 000000000000..39c9641719a4
--- /dev/null
+++ b/dev-util/glade/files/glade-3.14.1-doc-version.patch
@@ -0,0 +1,29 @@
+From e3e91245e730f0532e913fde910054f464085241 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 6 May 2012 22:40:47 -0400
+Subject: [PATCH] Version glade documentation
+
+Rename gnome help files to prevent collision with other versions.
+
+Avoid loading glade-3.8's devhelp files.
+---
+ help/Makefile.am | 5 ++++-
+ src/glade-window.c | 2 +-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/glade-window.c b/src/glade-window.c
+index 89a4549..4eb8be5 100644
+--- a/src/glade-window.c
++++ b/src/glade-window.c
+@@ -2041,7 +2041,7 @@ show_developer_manual_cb (GtkAction * action, GladeWindow * window)
+ {
+ if (glade_util_have_devhelp ())
+ {
+- glade_util_search_devhelp ("gladeui", NULL, NULL);
++ glade_util_search_devhelp ("gladeui-2", NULL, NULL);
+ return;
+ }
+
+--
+1.7.8.6
+
diff --git a/dev-util/glade/files/glade-3.18.1-underlinking.patch b/dev-util/glade/files/glade-3.18.1-underlinking.patch
new file mode 100644
index 000000000000..f34c03a2da58
--- /dev/null
+++ b/dev-util/glade/files/glade-3.18.1-underlinking.patch
@@ -0,0 +1,46 @@
+From 80c9532e39fac397960fc59eb407e596d9e8d2e4 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 2 Jun 2014 22:41:14 -0400
+Subject: [PATCH] build: Explicitly link libgladeui with libm
+
+Fixes underlinking failure with ld.gold.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=724104
+---
+ configure.ac | 6 ++++++
+ gladeui/Makefile.am | 2 +-
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c86e947..7bf65e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -133,6 +133,12 @@ AC_TRY_LINK([#include <stdarg.h>], [va_list ap1, ap2; va_copy(ap1, ap2);],
+ ])
+
+ dnl ================================================================
++dnl libm
++dnl ================================================================
++AC_CHECK_LIBM
++AC_SUBST(LIBM)
++
++dnl ================================================================
+ dnl Check for gtk-doc
+ dnl ================================================================
+ GTK_DOC_CHECK([1.13],[--flavour no-tmpl])
+diff --git a/gladeui/Makefile.am b/gladeui/Makefile.am
+index c63b6a3..77af09c 100644
+--- a/gladeui/Makefile.am
++++ b/gladeui/Makefile.am
+@@ -145,7 +145,7 @@ libgladeui_2_la_CFLAGS = \
+ $(AM_CFLAGS)
+
+ libgladeui_2_la_LDFLAGS = -version-info $(GLADE_CURRENT):$(GLADE_REVISION):$(GLADE_AGE) $(AM_LDFLAGS)
+-libgladeui_2_la_LIBADD = $(GTK_LIBS) $(GTK_MAC_LIBS)
++libgladeui_2_la_LIBADD = $(GTK_LIBS) $(GTK_MAC_LIBS) $(LIBM)
+
+ libgladeuiincludedir=$(includedir)/libgladeui-2.0/gladeui
+ libgladeuiinclude_HEADERS = \
+--
+2.0.0
+