summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-15 13:43:46 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-15 14:28:03 -0700
commita68d519248819d75b4d149d7c2491ee7710aedb4 (patch)
treedaac24504b9d953110b3cd0e6489c4caf4618930 /dev-util/glslang
parentdev-util/glslang: python3_8 (diff)
downloadgentoo-a68d519248819d75b4d149d7c2491ee7710aedb4.tar.gz
gentoo-a68d519248819d75b4d149d7c2491ee7710aedb4.tar.bz2
gentoo-a68d519248819d75b4d149d7c2491ee7710aedb4.zip
dev-util/glslang: Version bump to 8.13.3559
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/glslang')
-rw-r--r--dev-util/glslang/Manifest1
-rw-r--r--dev-util/glslang/glslang-8.13.3559.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/glslang/Manifest b/dev-util/glslang/Manifest
index 53cfd4cdf535..394c0ba8ed91 100644
--- a/dev-util/glslang/Manifest
+++ b/dev-util/glslang/Manifest
@@ -1 +1,2 @@
DIST glslang-7.12.3353_pre20191027.tar.gz 3119760 BLAKE2B 4a7eda7bf89b1589cb8a712660589e2746ff13ce3cac589a5651486fbdaa149b0fd8fceb791af0e43c9342aa9ca31459f66d0236c31d22959e519e8eb4457018 SHA512 6f247dbf9a50cdfe7b6ffbf79f73c46c57f8f61ef10037e0775ddd6faf4c5fd4b9b6b6761ecf26cc71c3711a650ee8619e2f0a33dfcf8ca8dc2974e497a685a7
+DIST glslang-8.13.3559.tar.gz 3122936 BLAKE2B 856e6068a06407195f97478b3e6bd91aa619213d8468a8c9ff7ee8e7a36a904e4896e34e021e8e4e047fab6ea406d89206849058a659de8075c52a06118b0e7b SHA512 d2f09888dd1b6edb4f324502627aeca0c78411f61ab50e672fa2a6d9ae46611849e1d13b9c6069b77f31092d843abcf3d74ed7cfc3c9144ced80e65876f4b781
diff --git a/dev-util/glslang/glslang-8.13.3559.ebuild b/dev-util/glslang/glslang-8.13.3559.ebuild
new file mode 100644
index 000000000000..7ce2721cbd0d
--- /dev/null
+++ b/dev-util/glslang/glslang-8.13.3559.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="!<media-libs/shaderc-2019-r1"
+BDEPEND="${PYTHON_DEPS}"
+
+# Bug 698850
+RESTRICT="test"