summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-13 14:45:32 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-13 14:45:32 +0200
commit2a9e8f9f293f98a875df4aa73acffa39adcf11df (patch)
tree2317e576df7bba2da4f287f5aff8a848d12d7da4 /dev-util/hadolint/hadolint-1.10.2.ebuild
parentdev-python/backports-unittest-mock: remove old (diff)
downloadgentoo-2a9e8f9f293f98a875df4aa73acffa39adcf11df.tar.gz
gentoo-2a9e8f9f293f98a875df4aa73acffa39adcf11df.tar.bz2
gentoo-2a9e8f9f293f98a875df4aa73acffa39adcf11df.zip
dev-util/hadolint: Version bump to 1.10.2
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'dev-util/hadolint/hadolint-1.10.2.ebuild')
-rw-r--r--dev-util/hadolint/hadolint-1.10.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/hadolint/hadolint-1.10.2.ebuild b/dev-util/hadolint/hadolint-1.10.2.ebuild
new file mode 100644
index 000000000000..51581f0faaa0
--- /dev/null
+++ b/dev-util/hadolint/hadolint-1.10.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Dockerfile Linter JavaScript API"
+HOMEPAGE="https://github.com/hadolint/hadolint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/gitrev-1.3.1:=[profile?]
+ >=dev-haskell/language-docker-6.0.3:=[profile?] <dev-haskell/language-docker-7:=[profile?]
+ >=dev-haskell/megaparsec-6.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14.0:=[profile?]
+ >=dev-haskell/split-0.2:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/void:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+ >=dev-util/shellcheck-0.5.0:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( dev-haskell/hspec
+ >=dev-haskell/hunit-1.2 )
+"
+
+src_prepare() {
+ default
+ sed -i -e "s/-static//" ${PN}.cabal || die
+}