summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-13 19:25:01 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-02-14 10:24:58 +0200
commitc608e0dcc129ea3abf2f1f56cf2db2c85ffd28ff (patch)
tree7d55c12fa8b9b0398836a232a5afcf72e992d25b /dev-util/hermes/hermes-9999.ebuild
parentdev-ruby/timers: add 4.3.3 (diff)
downloadgentoo-c608e0dcc129ea3abf2f1f56cf2db2c85ffd28ff.tar.gz
gentoo-c608e0dcc129ea3abf2f1f56cf2db2c85ffd28ff.tar.bz2
gentoo-c608e0dcc129ea3abf2f1f56cf2db2c85ffd28ff.zip
dev-util/hermes: move to commit version for >lua5.1 compat
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/hermes/hermes-9999.ebuild')
-rw-r--r--dev-util/hermes/hermes-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/hermes/hermes-9999.ebuild b/dev-util/hermes/hermes-9999.ebuild
new file mode 100644
index 000000000000..b7ca24876556
--- /dev/null
+++ b/dev-util/hermes/hermes-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} )
+inherit lua-single
+
+DESCRIPTION="Lua based testing manager"
+HOMEPAGE="https://github.com/TACC/Hermes"
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/TACC/Hermes"
+else
+ COMMIT="b99622087233178368cff6cf38ec72fa01dfd8a6"
+ SRC_URI="https://github.com/TACC/Hermes/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/Hermes-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ dev-lua/luaposix[${LUA_USEDEP}]
+ ')
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.8-lua-shebang.patch )
+
+src_compile() {
+ sed -e "s|@LUA@|${LUA}|g" \
+ -i lib/tool.lua \
+ -i bin/lua_cmd || die
+}
+
+src_test() {
+ local -x PATH="bin:${PATH}"
+ tm -vvv || die
+ testcleanup || die
+}
+
+src_install() {
+ dodir /opt/hermes
+ cp -r "${S}"/. "${ED}"/opt/hermes/ || die
+
+ doenvd "${FILESDIR}"/99hermes
+}