summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2022-09-02 16:25:49 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-09-12 16:41:01 +0800
commit617aabf1f78804a35d1cdf614e40d5873c813207 (patch)
treef05adcb4927feaeccfe69155a2a566099f0d3d4d /dev-util/hip/files/hip-5.1.3-remove-cmake-doxygen-commands.patch
parentdev-util/hip: Fix sample install dir (diff)
downloadgentoo-617aabf1f78804a35d1cdf614e40d5873c813207.tar.gz
gentoo-617aabf1f78804a35d1cdf614e40d5873c813207.tar.bz2
gentoo-617aabf1f78804a35d1cdf614e40d5873c813207.zip
dev-util/hip: Use docs.eclass to control doc install
By default, hip build documentation using doxygen in packaging/CMakeLists. Patch it out and use docs.eclass instead. Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-util/hip/files/hip-5.1.3-remove-cmake-doxygen-commands.patch')
-rw-r--r--dev-util/hip/files/hip-5.1.3-remove-cmake-doxygen-commands.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/hip/files/hip-5.1.3-remove-cmake-doxygen-commands.patch b/dev-util/hip/files/hip-5.1.3-remove-cmake-doxygen-commands.patch
new file mode 100644
index 000000000000..921452b2ba92
--- /dev/null
+++ b/dev-util/hip/files/hip-5.1.3-remove-cmake-doxygen-commands.patch
@@ -0,0 +1,21 @@
+Index: hipamd-rocm-5.1.3/packaging/CMakeLists.txt
+===================================================================
+--- hipamd-rocm-5.1.3.orig/packaging/CMakeLists.txt
++++ hipamd-rocm-5.1.3/packaging/CMakeLists.txt
+@@ -88,16 +88,6 @@ install(FILES ${CMAKE_BINARY_DIR}/includ
+ DESTINATION include/hip COMPONENT dev)
+ #End dev files install
+
+-#Begin doc files install
+-find_program(DOXYGEN_EXE doxygen)
+-if(DOXYGEN_EXE)
+- add_custom_target(build_doxygen ALL
+- COMMAND HIP_PATH=${HIP_COMMON_DIR} doxygen ${HIP_COMMON_DIR}/docs/doxygen-input/doxy.cfg)
+- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/RuntimeAPI/html
+- DESTINATION docs/RuntimeAPI COMPONENT doc)
+-endif()
+-#End doc files install
+-
+ #Begin samples files install
+ install(DIRECTORY ${HIP_COMMON_DIR}/samples DESTINATION ${CMAKE_INSTALL_DOCDIR}/ COMPONENT samples)
+ #End samples files install