summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-01-25 19:50:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:28 +0100
commit8c475e10d4fb382c332699e3cc0b5c90404fdc73 (patch)
treea1f78523d95ba50c0642389eb415233e81a81b6e /dev-util/hxd/hxd-0.70.02-r3.ebuild
parentmedia-libs/libfpx: EAPI8 bump, fix bug #847412 (diff)
downloadgentoo-8c475e10d4fb382c332699e3cc0b5c90404fdc73.tar.gz
gentoo-8c475e10d4fb382c332699e3cc0b5c90404fdc73.tar.bz2
gentoo-8c475e10d4fb382c332699e3cc0b5c90404fdc73.zip
dev-util/hxd: EAPI8 bump, fix HOMEPAGE, LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35016 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/hxd/hxd-0.70.02-r3.ebuild')
-rw-r--r--dev-util/hxd/hxd-0.70.02-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/hxd/hxd-0.70.02-r3.ebuild b/dev-util/hxd/hxd-0.70.02-r3.ebuild
new file mode 100644
index 000000000000..940b3d158d89
--- /dev/null
+++ b/dev-util/hxd/hxd-0.70.02-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Binary to hexadecimal converter"
+HOMEPAGE="https://linux.xulin.de/c/"
+SRC_URI="https://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-prll-flags.patch
+ "${FILESDIR}"/${P}-llong-redef.patch
+)
+
+DOCS=( README TODO )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}" "un${PN}"
+ doman "${PN}.1" "un${PN}.1"
+ einstalldocs
+}