summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-03-13 13:14:34 -0400
committerMike Pagano <mpagano@gentoo.org>2024-03-13 13:14:34 -0400
commitbe2699d17b1691375f1fc10b1ec4d06b045eff29 (patch)
treed656ed88a302efbeb3b1c8c891831c7933170767 /dev-util/idea-community
parentdev-cpp/cpp-httplib: disable failing tests (diff)
downloadgentoo-be2699d17b1691375f1fc10b1ec4d06b045eff29.tar.gz
gentoo-be2699d17b1691375f1fc10b1ec4d06b045eff29.tar.bz2
gentoo-be2699d17b1691375f1fc10b1ec4d06b045eff29.zip
dev-util/idea-community: add 2023.3.5
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/idea-community-2023.3.5.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 6f196ca08cd9..d755ae3389c8 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
DIST idea-community-2023.3.4-aarch64.tar.gz 817123037 BLAKE2B 08cca91d5cad34a292e79668c1096b344f52305700c82a93b33e5fb8182ec4708ccb62e74908a7a8ef6b36c1b41edc415b90c109039afc1840b257c605aff62e SHA512 ad33277002e818ac4dc751da19f428ccc4aedcf08c04bbb483d2e2a5c5d4704d1d4c111fb33d88593601c9aaefa25fb3c0cffec439be0e9909c09cec7579566d
DIST idea-community-2023.3.4-amd64.tar.gz 815935882 BLAKE2B 9ecd52dc1d00b5c733acd798b093ed2544d73368ba3016baaa3e360e4a4f714c6f7b39cc0a4da814fe7d8b8d83af10e633eb8fad26cd615d67423483f699fa0f SHA512 048a25e184be4a4739bc788050f2887a76cadcafc2d6033eed2d8ebaf5c71116140e9cd30b9cae24f244b50296a46effd83c099f897f79b1df74ec2995899602
+DIST idea-community-2023.3.5-aarch64.tar.gz 817137782 BLAKE2B 20d5d3b147b15cdbba6564a42828357e69e5a965a88007f049a2da84713c2b153d66b43d62135422e1c303bf297cfa1bfe877b42652173b3c6b4ee14c9faab71 SHA512 0e8709bc80d731ba6e2d601e288dc03d4bf0af3219a214e76ae4b7fb44a8405d07f800148283ce7c517f5de8ca98fecbdd2dfc28f75122b01352a5cbb6d2893d
+DIST idea-community-2023.3.5-amd64.tar.gz 815949614 BLAKE2B c1b5b39c7589ff268137ff12317a6c223755868de12eda5fd5e2a16963b52b40697744c8e7da7aabb9b41442062f056463fca09d5d1bfdaec4232c1ff1fe9d5e SHA512 7543aae6aacacd86b52ff6fcc9e151238f3904d678a7870acf38d19ff14508bed17f46fab06b2cb78dd20dae5a1c1a027e8d01bf1f738f02e11703808fa290b7
diff --git a/dev-util/idea-community/idea-community-2023.3.5.ebuild b/dev-util/idea-community/idea-community-2023.3.5.ebuild
new file mode 100644
index 000000000000..6dccef36ed45
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2023.3.5.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+SRC_URI="
+ amd64? ( https://download.jetbrains.com/idea/ideaIC-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( https://download.jetbrains.com/idea/ideaIC-${PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
+ "
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.8.1_p1:17
+ >=dev-java/openjdk-bin-17.0.8.1_p1:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ dev-libs/libdbusmenu"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+S="${WORKDIR}/idea-IC-${PV}"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+ else
+ JRE_DIR=jre
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restarter,fsnotifier}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+
+ # remove bundled java
+ rm -r ${dst}/jbr || die "Unable to remove bundled java"
+
+}