summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-02-15 08:04:56 -0500
committerMike Pagano <mpagano@gentoo.org>2024-02-15 08:05:07 -0500
commitd574c8f74a5b027edf815ab8bca40d557dd4d1ad (patch)
tree6027f4e1461a2ecb0d8ede214c4ee71de9d7af90 /dev-util/idea-community
parentdev-util/idea-community: add 2023.3.4 (diff)
downloadgentoo-d574c8f74a5b027edf815ab8bca40d557dd4d1ad.tar.gz
gentoo-d574c8f74a5b027edf815ab8bca40d557dd4d1ad.tar.bz2
gentoo-d574c8f74a5b027edf815ab8bca40d557dd4d1ad.zip
dev-util/idea-community: drop 2023.3.3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest1
-rw-r--r--dev-util/idea-community/idea-community-2023.3.3.ebuild129
2 files changed, 0 insertions, 130 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 51a6ca453d10..23df8d0bce6a 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1 @@
-DIST idea-community-2023.3.3.tar.gz 815817613 BLAKE2B 987b5585d85bfd7a62acc6bedadc6c7a6a154e477e6c9706ccd554e41c25f32c7dd4b02545342f16e6971a40b9f60acb22dce64413fa7495feaa5230f97a5d62 SHA512 6211258320a6a892e8d1cdc56c17e304dc69d3effc4fd688d9ba53173b9672bc85fe4e321e207e2e5694097f5a17f7d4a773acaf1428f453a1119055cc17ea1e
DIST idea-community-2023.3.4.tar.gz 815935882 BLAKE2B 9ecd52dc1d00b5c733acd798b093ed2544d73368ba3016baaa3e360e4a4f714c6f7b39cc0a4da814fe7d8b8d83af10e633eb8fad26cd615d67423483f699fa0f SHA512 048a25e184be4a4739bc788050f2887a76cadcafc2d6033eed2d8ebaf5c71116140e9cd30b9cae24f244b50296a46effd83c099f897f79b1df74ec2995899602
diff --git a/dev-util/idea-community/idea-community-2023.3.3.ebuild b/dev-util/idea-community/idea-community-2023.3.3.ebuild
deleted file mode 100644
index 47b41da9281c..000000000000
--- a/dev-util/idea-community/idea-community-2023.3.3.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit desktop wrapper
-
-DESCRIPTION="A complete toolset for web, mobile and enterprise development"
-HOMEPAGE="https://www.jetbrains.com/idea"
-SRC_URI="https://download.jetbrains.com/idea/ideaIC-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
- codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
- GPL-2 GPL-2-with-classpath-exception ISC
- JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
- MPL-1.0 MPL-1.1 OFL ZLIB"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-DEPEND="
- || (
- >=dev-java/openjdk-17.0.8.1_p1:17
- >=dev-java/openjdk-bin-17.0.8.1_p1:17
- )"
-
-RDEPEND="${DEPEND}
- sys-libs/glibc
- media-libs/harfbuzz
- dev-java/jansi-native
- dev-libs/libdbusmenu"
-
-BDEPEND="dev-util/patchelf"
-RESTRICT="splitdebug"
-S="${WORKDIR}/idea-IC-${PV}"
-
-QA_PREBUILT="opt/${PN}/*"
-
-src_unpack() {
-
- default_src_unpack
- if [ ! -d "$S" ]; then
- einfo "Renaming source directory to predictable name..."
- mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
- fi
-}
-
-src_prepare() {
-
- default_src_prepare
-
- if use amd64; then
- JRE_DIR=jre64
- else
- JRE_DIR=jre
- fi
-
- PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
-
- # rm LLDBFrontEnd after licensing questions with Gentoo License Team
- rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
- rm -vf ${PLUGIN_DIR}/libavplugin*
- rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
- rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
- rm -vf "${S}"/bin/libdbm64*
- rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
- rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
-
- if [[ -d "${S}"/"${JRE_DIR}" ]]; then
- for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
- do
- if [[ -f "$file" ]]; then
- patchelf --set-rpath '$ORIGIN' $file || die
- fi
- done
- fi
-
- rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
-
- sed -i \
- -e "\$a\\\\" \
- -e "\$a#-----------------------------------------------------------------------" \
- -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
- -e "\$a# package manager. See bug #704494" \
- -e "\$a#-----------------------------------------------------------------------" \
- -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
-
- eapply_user
-}
-
-src_install() {
- local dir="/opt/${PN}"
- local dst="${D}${dir}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restarter,fsnotifier}
- if use amd64; then
- JRE_DIR=jre64
- else
- JRE_DIR=jre
- fi
-
- JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
- if [[ -d ${JRE_DIR} ]]; then
- for jrebin in $JRE_BINARIES; do
- fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
- done
- fi
-
- # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
- local bundled_script_name="${PN%-*}.sh"
- make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
-
- local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
- newicon $pngfile "${PN}.png" || die "we died"
-
- make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- mkdir -p "${D}/etc/sysctl.d/" || die
- echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
-
- # remove bundled harfbuzz
- rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
-
- # remove bundled java
- rm -r ${dst}/jbr || die "Unable to remove bundled java"
-
-}