summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-10-12 17:55:45 -0400
committerMike Pagano <mpagano@gentoo.org>2023-10-12 17:55:45 -0400
commite9e9bc7002ca97b73d96dddbd787c188cc239a05 (patch)
treecf4b996e0ae1a5fb68963b7028e084cc09f8b147 /dev-util/idea-community
parentmedia-sound/openmpt123: Bump to 0.7.3, drop old 0.7.2 (diff)
downloadgentoo-e9e9bc7002ca97b73d96dddbd787c188cc239a05.tar.gz
gentoo-e9e9bc7002ca97b73d96dddbd787c188cc239a05.tar.bz2
gentoo-e9e9bc7002ca97b73d96dddbd787c188cc239a05.zip
dev-util/idea-community: add 2023.2.3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest1
-rw-r--r--dev-util/idea-community/idea-community-2023.2.3.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index c5b143394571..cec5f1a9f474 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1 +1,2 @@
DIST idea-community-2023.2.2.tar.gz 974152883 BLAKE2B e9b54265514f7ce6161590264b62ea2989223d4d038c0ecd9ae653afa5d6c873f1d4bc4608d77bf2f892744ba1acb726692f563590d7d3b18d9f360a32ceba81 SHA512 b8c1be37aea787ca4461f3ac3ee3857c40792a478e1cd7922435277bb736e7e693507b34b99fe18f3896ee7d966e6f7ef5355f3fedec02abfdcb16678a08785d
+DIST idea-community-2023.2.3.tar.gz 974257506 BLAKE2B 40348fe265aa7c135f40383ff078a22ec49d6ada04d7661fdb6145f1d3cbb44ac1707d5ad15aa5bb8b5436f1578bff5558ad2420943ec99b95f963beeed7ce69 SHA512 67a56d63517bd3ffa0c9876dc12a7884ff8bf1ff2f5c655244b637b1228d5126b1065f712fc112d1197e22b5479d42a288d3dcf91b550f2c0e99c0fc5f7969e5
diff --git a/dev-util/idea-community/idea-community-2023.2.3.ebuild b/dev-util/idea-community/idea-community-2023.2.3.ebuild
new file mode 100644
index 000000000000..8e9da1056bd7
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2023.2.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+SRC_URI="https://download.jetbrains.com/idea/ideaIC-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.6_p10:17
+ >=dev-java/openjdk-bin-17.0.6_p10:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ dev-libs/libdbusmenu"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+S="${WORKDIR}/idea-IC-${PV}"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restart.py,fsnotifier}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+
+ # remove bundled java
+ rm -r ${dst}/jbr || die "Unable to remove bundled java"
+
+}