summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-06-22 18:50:07 -0400
committerMike Pagano <mpagano@gentoo.org>2023-06-22 18:50:07 -0400
commitf7ce8fcd6fbf0e6b9796cf6886b4b42f1a750cc8 (patch)
tree3ae617a021ad595b2e1f132c74a08851348319ef /dev-util/idea-community
parentdev-util/idea-community: add 2023.1.3 (diff)
downloadgentoo-f7ce8fcd6fbf0e6b9796cf6886b4b42f1a750cc8.tar.gz
gentoo-f7ce8fcd6fbf0e6b9796cf6886b4b42f1a750cc8.tar.bz2
gentoo-f7ce8fcd6fbf0e6b9796cf6886b4b42f1a750cc8.zip
dev-util/idea-community: drop 2023.1.2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest1
-rw-r--r--dev-util/idea-community/idea-community-2023.1.2.ebuild129
2 files changed, 0 insertions, 130 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index a049f12cee71..f013e77a96bd 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1 @@
-DIST idea-community-2023.1.2.tar.gz 938083157 BLAKE2B 9f7195ad6b435f36fa9f7e67e6da39a5f728c6c2b47af982e11b13d8b763600f5b92d5373bc535ae81c86e6bfb6f94b1e62851def1c84cb112e783a9b759a0b5 SHA512 c859fbe0ef58978891d5a12f14c3507aa3bc65497bab3e407e0bcb924dcebe8ec009bbc3d8dd22b15092d8c646251bf2a04ba076c788a21af42efdff01bcf149
DIST idea-community-2023.1.3.tar.gz 938144163 BLAKE2B e7bc2aec4ad0642828607a0e83d7dc459209812704243898486e8af7a348bc9794af6d534f1e1420084fe4fa0284c17dd09d151698bf6b8fb7ca29457ebcfbfe SHA512 f9873ca1da69611e9b4dfeb05a03a87cbc1b5ec686426276101019fb70942192d744067e7a5155298576a8766f35c9e50fcf7ba6f8d20f913ee1e5b7cc8c5fe2
diff --git a/dev-util/idea-community/idea-community-2023.1.2.ebuild b/dev-util/idea-community/idea-community-2023.1.2.ebuild
deleted file mode 100644
index 8e9da1056bd7..000000000000
--- a/dev-util/idea-community/idea-community-2023.1.2.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit desktop wrapper
-
-DESCRIPTION="A complete toolset for web, mobile and enterprise development"
-HOMEPAGE="https://www.jetbrains.com/idea"
-SRC_URI="https://download.jetbrains.com/idea/ideaIC-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
- codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
- GPL-2 GPL-2-with-classpath-exception ISC
- JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
- MPL-1.0 MPL-1.1 OFL ZLIB"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-DEPEND="
- || (
- >=dev-java/openjdk-17.0.6_p10:17
- >=dev-java/openjdk-bin-17.0.6_p10:17
- )"
-
-RDEPEND="${DEPEND}
- sys-libs/glibc
- media-libs/harfbuzz
- dev-java/jansi-native
- dev-libs/libdbusmenu"
-
-BDEPEND="dev-util/patchelf"
-RESTRICT="splitdebug"
-S="${WORKDIR}/idea-IC-${PV}"
-
-QA_PREBUILT="opt/${PN}/*"
-
-src_unpack() {
-
- default_src_unpack
- if [ ! -d "$S" ]; then
- einfo "Renaming source directory to predictable name..."
- mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
- fi
-}
-
-src_prepare() {
-
- default_src_prepare
-
- if use amd64; then
- JRE_DIR=jre64
- else
- JRE_DIR=jre
- fi
-
- PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
-
- # rm LLDBFrontEnd after licensing questions with Gentoo License Team
- rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
- rm -vf ${PLUGIN_DIR}/libavplugin*
- rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
- rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
- rm -vf "${S}"/bin/libdbm64*
- rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
- rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
-
- if [[ -d "${S}"/"${JRE_DIR}" ]]; then
- for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
- do
- if [[ -f "$file" ]]; then
- patchelf --set-rpath '$ORIGIN' $file || die
- fi
- done
- fi
-
- rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
-
- sed -i \
- -e "\$a\\\\" \
- -e "\$a#-----------------------------------------------------------------------" \
- -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
- -e "\$a# package manager. See bug #704494" \
- -e "\$a#-----------------------------------------------------------------------" \
- -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
-
- eapply_user
-}
-
-src_install() {
- local dir="/opt/${PN}"
- local dst="${D}${dir}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restart.py,fsnotifier}
- if use amd64; then
- JRE_DIR=jre64
- else
- JRE_DIR=jre
- fi
-
- JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
- if [[ -d ${JRE_DIR} ]]; then
- for jrebin in $JRE_BINARIES; do
- fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
- done
- fi
-
- # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
- local bundled_script_name="${PN%-*}.sh"
- make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
-
- local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
- newicon $pngfile "${PN}.png" || die "we died"
-
- make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- mkdir -p "${D}/etc/sysctl.d/" || die
- echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
-
- # remove bundled harfbuzz
- rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
-
- # remove bundled java
- rm -r ${dst}/jbr || die "Unable to remove bundled java"
-
-}