summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-04-29 21:09:44 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-04-29 21:16:34 +0200
commit9c479450dfc4080bb682ac6803107efe2422b81c (patch)
tree29d9a5b44c28f331045ec8707513af9bceb7da2e /dev-util/include-what-you-use/include-what-you-use-0.19.ebuild
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-9c479450dfc4080bb682ac6803107efe2422b81c.tar.gz
gentoo-9c479450dfc4080bb682ac6803107efe2422b81c.tar.bz2
gentoo-9c479450dfc4080bb682ac6803107efe2422b81c.zip
dev-util/include-what-you-use: fix tests
1. invoke run_iwyu_tests with "-- ${BUILD_DIR}/bin/${PN}", so that the just build iwyu is used and not the one potentially available in PATH 2. Fix include path, see https://github.com/include-what-you-use/include-what-you-use/pull/1252 3. Drop stddef from badinc.cc. This makes the test pass. I am not sure if this is correct or not, but at the moment it was either this or dropping the test entirely. Closes: https://bugs.gentoo.org/905214 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-util/include-what-you-use/include-what-you-use-0.19.ebuild')
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-0.19.ebuild21
1 files changed, 19 insertions, 2 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-0.19.ebuild b/dev-util/include-what-you-use/include-what-you-use-0.19.ebuild
index 367e7c6d5101..eb3c6a7e4c82 100644
--- a/dev-util/include-what-you-use/include-what-you-use-0.19.ebuild
+++ b/dev-util/include-what-you-use/include-what-you-use-0.19.ebuild
@@ -9,7 +9,11 @@ inherit cmake llvm python-single-r1
DESCRIPTION="Find unused include directives in C/C++ programs"
HOMEPAGE="https://include-what-you-use.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/include-what-you-use/include-what-you-use/commit/62e5e2e35380e46ccbff2c2ed118f8bb5c01755b.patch
+ -> ${PN}-0.19-test-util-support-EXTRA_IWYU_ARGS.patch
+"
LICENSE="GPL-2"
SLOT="0"
@@ -26,6 +30,12 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+PATCHES=(
+ # https://github.com/include-what-you-use/include-what-you-use/pull/1252
+ "${DISTDIR}"/${PN}-0.19-test-util-support-EXTRA_IWYU_ARGS.patch
+ "${FILESDIR}"/${PN}-0.19-tests-cxx-badinc.cc-remove-stddef-from-expected.patch
+)
+
llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
@@ -54,5 +64,12 @@ src_configure() {
}
src_test() {
- "${EPYTHON}" run_iwyu_tests.py || die
+ local clang_version=$(best_version sys-devel/clang:${LLVM_MAX_SLOT})
+ clang_version=${clang_version#*/*-} # reduce it to ${PV}-${PR}
+ clang_version=${clang_version%%[_-]*} # main version without beta/pre/patch/revision
+
+ local -x EXTRA_IWYU_ARGS="-I ${ESYSROOT}/usr/lib/clang/${clang_version}/include"
+ "${EPYTHON}" run_iwyu_tests.py \
+ -- "${BUILD_DIR}"/bin/${PN} \
+ || die "Tests failed with $? (using ${EPYTHON})"
}