summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-26 13:25:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-26 13:26:22 +0100
commit0e59b06032035c32fa7cfb53d60a45b720490dd4 (patch)
treede07776bc24130fe25867085ab1ccdf3d822e2cf /dev-util/include-what-you-use/include-what-you-use-9.0.ebuild
parentsys-process/psmisc: Removed obsolete peekfd compile hack (diff)
downloadgentoo-0e59b06032035c32fa7cfb53d60a45b720490dd4.tar.gz
gentoo-0e59b06032035c32fa7cfb53d60a45b720490dd4.tar.bz2
gentoo-0e59b06032035c32fa7cfb53d60a45b720490dd4.zip
dev-util/include-what-you-use: bump up to 9.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/include-what-you-use/include-what-you-use-9.0.ebuild')
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-9.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-9.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-9.0.ebuild
new file mode 100644
index 000000000000..2b95d9035551
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-9.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit cmake-utils flag-o-matic llvm python-single-r1
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/clang_${PV}.tar.gz -> ${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LLVM_MAX_SLOT=9
+
+RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAX_SLOT}
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-clang_${PV}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Note [llvm install path]
+ # Unfortunately all binaries using clang driver
+ # have to reside at the same path depth as
+ # 'clang' binary itself. See bug #625972
+ # Thus as a hack we install it to the same directory
+ # as llvm/clang itself.
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py
+}