summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-04-30 15:54:04 +0100
committerMarek Szuba <marecki@gentoo.org>2019-05-01 17:51:33 +0100
commit8064dd92a637ddc882ce7e5beaf229618ab478f2 (patch)
treefd23e2cca408135fd46f0dffdd820badcfd51252 /dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild
parentdev-libs/opencl-clang: new package (diff)
downloadgentoo-8064dd92a637ddc882ce7e5beaf229618ab478f2.tar.gz
gentoo-8064dd92a637ddc882ce7e5beaf229618ab478f2.tar.bz2
gentoo-8064dd92a637ddc882ce7e5beaf229618ab478f2.zip
dev-util/intel-graphics-compiler: new package
First-order dependency of Intel Graphics Compute Runtime. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild')
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild
new file mode 100644
index 000000000000..b15c94ceace5
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ dev-libs/opencl-clang:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCCLANG_BUILD_INTREE_LLVM=OFF
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix)/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=8
+ # Until a new official release of opencl-clang
+ -DCOMMON_CLANG_LIBRARY_NAME=common_clang
+ )
+ cmake-utils_src_configure
+}