summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-29 23:29:55 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-29 23:29:55 +0200
commit5beac4fec56bb35f1b9da2f420b21da2ce4f9a30 (patch)
treee62a170ba2c673fc40f48e8b26c8338462ffd527 /dev-util/intel-graphics-compiler
parentdev-util/intel-graphics-compiler: amd64 stable (diff)
downloadgentoo-5beac4fec56bb35f1b9da2f420b21da2ce4f9a30.tar.gz
gentoo-5beac4fec56bb35f1b9da2f420b21da2ce4f9a30.tar.bz2
gentoo-5beac4fec56bb35f1b9da2f420b21da2ce4f9a30.zip
dev-util/intel-graphics-compiler: drop old version
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 4e859bfa6a98..e5aba1fbdb5d 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1 @@
-DIST intel-graphics-compiler-1.0.8708.tar.gz 7574517 BLAKE2B 578b29a103d3d0b7f481971a801fa11bc14430b7ecd00c99492f5d80ce713b84d00d278726a425edf5884ac15f4877c96a39a3f3f3f1c22bc972db039be28dc2 SHA512 3685c2fe0750d860facd7f378a1de4ac21127e7720d7a8889ac0ae8ab9e58dfacfc50b5bbe37d5744c9a17958b057512871125b58784a8c62ddffc2997f80ba8
DIST intel-graphics-compiler-1.0.8744.tar.gz 7586378 BLAKE2B 0f20f99a2659f733521af35c1dd63c2b1398bf4fc5745a217b96ad62cfa53f105d4c9a34eba09651d0f0679d6957820011446f5657170f5ad07d110372b8b1f3 SHA512 dbbe6c08f32b80be305add570187df883aacefbf90b252c70b5705ecc7732f25873732a85558f0aed2ee8db5bcd1a59aec4d7ba110774922dbb19d4d3522a539
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild
deleted file mode 100644
index 21d5303b49fa..000000000000
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_BUILD_TYPE="Release"
-LLVM_MAX_SLOT="11"
-MY_PN="igc"
-MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake flag-o-matic llvm python-any-r1
-
-DESCRIPTION="LLVM-based OpenCL compiler for OpenCL targetting Intel Gen graphics hardware"
-HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
-SRC_URI="https://github.com/intel/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="debug"
-
-DEPEND="
- dev-libs/opencl-clang:${LLVM_MAX_SLOT}=
- sys-devel/llvm:${LLVM_MAX_SLOT}=
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- ${PYTHON_DEPS}
- >=sys-devel/lld-${LLVM_MAX_SLOT}
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
- "${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
- "${FILESDIR}/${PN}-1.0.8365-disable-git.patch"
- "${FILESDIR}/${PN}-1.0.8365-cmake-project.patch"
-)
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- # Since late March 2020 cmake.eclass does not set -DNDEBUG any more,
- # and the way IGC uses this definition causes problems for some users.
- # See bug #718824 for more information.
- ! use debug && append-cppflags -DNDEBUG
-
- # Get LLVM version
- local llvm_version="$(best_version -d sys-devel/llvm:${LLVM_MAX_SLOT})"
-
- local mycmakeargs=(
- # Those options are ensuring, that we are using
- # the system LLVM with the correct slot.
- -DCCLANG_SONAME_VERSION="${LLVM_MAX_SLOT}"
- -DCMAKE_LIBRARY_PATH="$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)"
- -DIGC_OPTION__ARCHITECTURE_TARGET="Linux64"
- -DIGC_OPTION__CLANG_MODE="Prebuilds"
- -DIGC_OPTION__LLD_MODE="Prebuilds"
- -DIGC_OPTION__LLDELF_H_DIR="${EPREFIX}/usr/include/lld/Common"
- -DIGC_OPTION__LLVM_MODE="Prebuilds"
- -DIGC_OPTION__LLVM_PREFERRED_VERSION="${llvm_version##*-}"
-
- # VectorCompiler needs work, as at the moment upstream
- # only supports building vc-intrinsics in place.
- -DIGC_BUILD__VC_ENABLED="NO"
-
- # This will suspress some CMake warnings,
- # which cannot be fixed at the moment.
- -Wno-dev
- )
-
- cmake_src_configure
-}