summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/intel-ocl-sdk/intel-ocl-sdk-4.4.0.117-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/intel-ocl-sdk/intel-ocl-sdk-4.4.0.117-r1.ebuild')
-rw-r--r--dev-util/intel-ocl-sdk/intel-ocl-sdk-4.4.0.117-r1.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/intel-ocl-sdk/intel-ocl-sdk-4.4.0.117-r1.ebuild b/dev-util/intel-ocl-sdk/intel-ocl-sdk-4.4.0.117-r1.ebuild
new file mode 100644
index 000000000000..1db1d9392488
--- /dev/null
+++ b/dev-util/intel-ocl-sdk/intel-ocl-sdk-4.4.0.117-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit rpm multilib
+
+DESCRIPTION="Intel's implementation of the OpenCL standard"
+HOMEPAGE="http://software.intel.com/en-us/articles/opencl-sdk/"
+SRC_URI="http://registrationcenter.intel.com/irc_nas/4181/intel_sdk_for_ocl_applications_2014_ubuntu_${PV}_x64.tgz"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+IUSE="android +system-tbb system-clang +system-boost +system-qt"
+KEYWORDS="-* ~amd64"
+RESTRICT="mirror"
+
+RDEPEND="app-eselect/eselect-opencl
+ sys-process/numactl
+ system-tbb? ( >=dev-cpp/tbb-4.2.20131118 )
+ system-clang? ( =sys-devel/clang-3.4* )
+ system-boost? ( >=dev-libs/boost-1.52.0:= )
+ system-qt? (
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtcore-4.8.5:4
+ )
+ "
+DEPEND=""
+
+S=${WORKDIR}/intel_sdk_for_ocl_applications_2014_ubuntu_${PV}_x64/
+INTEL_CL=opt/intel/opencl-1.2-${PV}
+INTEL_VENDOR_DIR=usr/$(get_libdir)/OpenCL/vendors/intel/
+
+QA_PREBUILT="${INTEL_OCL}/*"
+
+src_unpack() {
+ default
+
+ PKGS="base devel intel-cpu intel-devel"
+
+ use android && PKGS="$PKGS intel-devel-android"
+
+ for PKG in ${PKGS}; do
+ FILENAME="opencl-1.2-${PKG}-4.4.0.117-1.x86_64.deb"
+ einfo "Extracting \"${FILENAME}\"..."
+ ar x "${S}/$FILENAME" || die
+ unpack ./data.tar.gz
+ done
+}
+
+src_prepare() {
+ # Remove bundled stuff
+ if use system-boost; then
+ rm -f "${WORKDIR}/${INTEL_CL}"/lib64/libboost*.so*
+ fi
+ if use system-clang; then
+ rm -f "${WORKDIR}/${INTEL_CL}"/lib64/libclang*
+ fi
+ if use system-qt; then
+ rm -f "${WORKDIR}/${INTEL_CL}"/lib64/libQt*
+ fi
+ if use system-tbb; then
+ rm -f "${WORKDIR}/${INTEL_CL}"/lib64/libtbb*
+ fi
+}
+
+src_install() {
+ insinto /etc/OpenCL/vendors/
+ doins "${WORKDIR}/${INTEL_CL}"/etc/intel64.icd
+
+ insinto /"${INTEL_CL}"/lib64
+ insopts -m 755
+ doins "${WORKDIR}/${INTEL_CL}"/lib64/*
+
+ insinto /"${INTEL_CL}"/bin
+ doins "${WORKDIR}"/"${INTEL_CL}"/bin/*
+
+ # TODO put this somewhere
+ # doins ${INTEL_CL}/eclipse-plug-in/OpenCL_SDK_0.1.0.jar
+
+ dodir "${INTEL_VENDOR_DIR}"
+ dosym "/opt/intel/opencl-1.2-${PV}/lib64/libOpenCL.so" "${INTEL_VENDOR_DIR}/libOpenCL.so"
+ dosym "/opt/intel/opencl-1.2-${PV}/lib64/libOpenCL.so.1" "${INTEL_VENDOR_DIR}/libOpenCL.so.1"
+ dosym "/opt/intel/opencl-1.2-${PV}/lib64/libOpenCL.so.1.2" "${INTEL_VENDOR_DIR}/libOpenCL.so.1.2"
+}
+
+pkg_postinst() {
+ eselect opencl set --use-old intel
+}