summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-22 23:39:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-22 23:59:48 +0200
commit8c21c5403f361c4bde6ea248c5198d0328ef3108 (patch)
treec1297294fd5398897710e7cf6b67438824f201a5 /dev-util/kdevelop
parentapp-text/ebook-tools: EAPI-7, cmake.eclass, crashfix (diff)
downloadgentoo-8c21c5403f361c4bde6ea248c5198d0328ef3108.tar.gz
gentoo-8c21c5403f361c4bde6ea248c5198d0328ef3108.tar.bz2
gentoo-8c21c5403f361c4bde6ea248c5198d0328ef3108.zip
dev-util/kdevelop: Add missed subslot bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/kdevelop')
-rw-r--r--dev-util/kdevelop/kdevelop-5.6.0-r1.ebuild (renamed from dev-util/kdevelop/kdevelop-5.6.0.ebuild)38
1 files changed, 13 insertions, 25 deletions
diff --git a/dev-util/kdevelop/kdevelop-5.6.0.ebuild b/dev-util/kdevelop/kdevelop-5.6.0-r1.ebuild
index 5a3edac39a3b..262a77ad4251 100644
--- a/dev-util/kdevelop/kdevelop-5.6.0.ebuild
+++ b/dev-util/kdevelop/kdevelop-5.6.0-r1.ebuild
@@ -6,21 +6,21 @@ EAPI=7
ECM_HANDBOOK="forceoptional"
ECM_TEST="true"
KDE_ORG_CATEGORY="kdevelop"
-KFMIN=5.70.0
-QTMIN=5.12.3
+KFMIN=5.74.0
+QTMIN=5.15.1
VIRTUALDBUS_TEST="true"
VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
+inherit ecm kde.org optfeature
DESCRIPTION="Integrated Development Environment, supporting KF5/Qt, C/C++ and much more"
-HOMEPAGE="https://www.kdevelop.org/"
+HOMEPAGE="https://kdevelop.org/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="GPL-2 LGPL-2"
-SLOT="5/55" # look at KDEVELOP_SOVERSION inside CMakeLists.txt
+SLOT="5/56" # look at KDEVELOP_SOVERSION inside CMakeLists.txt
IUSE="+gdbui hex +plasma +qmake reviewboard subversion"
COMMON_DEPEND="
@@ -121,25 +121,13 @@ src_configure() {
}
pkg_postinst() {
- ecm_pkg_postinst
-
- if ! has_version "kde-apps/konsole" ; then
- elog "For konsole view, please install kde-apps/konsole"
- fi
-
- if ! has_version "dev-util/cppcheck" ; then
- elog "For static C/C++ code analysis support, please install dev-util/cppcheck"
- fi
-
- if ! has_version "dev-util/heaptrack[qt5]" ; then
- elog "For heap memory profiling support, please install dev-util/heaptrack"
- fi
-
- if ! has_version "dev-util/clazy" ; then
- elog "For static C++ Qt code analysis support, please install dev-util/clazy"
- fi
-
- if ! has_version ">=dev-util/meson-0.51" ; then
- elog "For the Meson Project manager plugin, please install dev-util/meson"
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "konsole view" kde-apps/konsole
+ optfeature "Static C++ Qt code analysis" dev-util/clazy
+ optfeature "Static C/C++ code analysis" dev-util/cppcheck
+ optfeature "Heap memory profiling" dev-util/heaptrack[qt5]
+ optfeature "Meson Project manager plugin" dev-util/meson
fi
+ ecm_pkg_postinst
}