summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-01 09:37:33 +0100
committerSam James <sam@gentoo.org>2024-05-01 09:37:33 +0100
commit8c9ebc5c7b5db6b4f7e525168e532ac52c80f472 (patch)
treef0c619fb318a90c6874f931c5d4a1e2521d90b2a /dev-util/lcov/lcov-1.16-r1.ebuild
parentdev-perl/Path-Dispatcher: add dev-perl/Test-Fatal test dep (diff)
downloadgentoo-8c9ebc5c7b5db6b4f7e525168e532ac52c80f472.tar.gz
gentoo-8c9ebc5c7b5db6b4f7e525168e532ac52c80f472.tar.bz2
gentoo-8c9ebc5c7b5db6b4f7e525168e532ac52c80f472.zip
dev-util/lcov: drop 1.15, 1.16-r1, 2.0-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lcov/lcov-1.16-r1.ebuild')
-rw-r--r--dev-util/lcov/lcov-1.16-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-util/lcov/lcov-1.16-r1.ebuild b/dev-util/lcov/lcov-1.16-r1.ebuild
deleted file mode 100644
index 11ab700358b7..000000000000
--- a/dev-util/lcov/lcov-1.16-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
-fi
-
-inherit optfeature prefix
-
-DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
-HOMEPAGE="https://github.com/linux-test-project/lcov"
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-RDEPEND="
- dev-lang/perl
- dev-perl/JSON
- dev-perl/PerlIO-gzip
-"
-
-src_prepare() {
- default
- if use prefix; then
- hprefixify bin/*.{pl,sh}
- fi
-}
-
-src_compile() { :; }
-
-src_test() {
- emake -j1 check
-}
-
-src_install() {
- emake -j1 \
- DESTDIR="${D}" \
- CFG_DIR="${EPREFIX}/etc" \
- PREFIX="${EPREFIX}/usr" \
- LCOV_PERL_PATH="${EPREFIX}/usr/bin/perl" \
- install
-}
-
-pkg_postinst() {
- optfeature "png output support" dev-perl/GD[png]
-}