summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-19 20:54:55 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-19 23:21:44 +0100
commit70f3c921f0256c2443e123b57f82b5e3af8fdbf6 (patch)
treeace38c29a6286d2193f8af52a812582e62196355 /dev-util/lldb/lldb-9999.ebuild
parentdev-util/lldb: Pass test options only if tests are enabled (diff)
downloadgentoo-70f3c921f0256c2443e123b57f82b5e3af8fdbf6.tar.gz
gentoo-70f3c921f0256c2443e123b57f82b5e3af8fdbf6.tar.bz2
gentoo-70f3c921f0256c2443e123b57f82b5e3af8fdbf6.zip
dev-util/lldb: Utilize LLDB_USE_SYSTEM_SIX
Use LLDB_USE_SYSTEM_SIX to disable installing the bundled six module instead of removing it manually. Closes: https://bugs.gentoo.org/645042
Diffstat (limited to 'dev-util/lldb/lldb-9999.ebuild')
-rw-r--r--dev-util/lldb/lldb-9999.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-util/lldb/lldb-9999.ebuild b/dev-util/lldb/lldb-9999.ebuild
index 405a88ed3c33..7e422adecfd2 100644
--- a/dev-util/lldb/lldb-9999.ebuild
+++ b/dev-util/lldb/lldb-9999.ebuild
@@ -67,6 +67,7 @@ src_configure() {
-DLLDB_DISABLE_CURSES=$(usex !ncurses)
-DLLDB_DISABLE_LIBEDIT=$(usex !libedit)
-DLLDB_DISABLE_PYTHON=$(usex !python)
+ -DLLDB_USE_SYSTEM_SIX=1
-DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-DLLDB_INCLUDE_TESTS=$(usex test)
@@ -105,9 +106,6 @@ src_install() {
# oh my...
if use python; then
- # remove bundled six module
- rm "${D}$(python_get_sitedir)/six.py" || die
-
# remove custom readline.so for now
# TODO: figure out how to deal with it
# upstream is basically building a custom readline.so with -ledit