summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-12-13 13:10:52 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-12-13 13:11:45 -0600
commitfaf6ae3c12e0d2c8f0a1ebbf67f61730704f2c2d (patch)
treef949e8410f098467e9dbe3adf4d61bfd0d973b99 /dev-util/log4shelldetect/log4shelldetect-0.0.4.ebuild
parentdev-python/bandit: Stabilize 1.7.1 arm64, #829108 (diff)
downloadgentoo-faf6ae3c12e0d2c8f0a1ebbf67f61730704f2c2d.tar.gz
gentoo-faf6ae3c12e0d2c8f0a1ebbf67f61730704f2c2d.tar.bz2
gentoo-faf6ae3c12e0d2c8f0a1ebbf67f61730704f2c2d.zip
dev-util/log4shelldetect: scans for vulnerabilities to log4shell
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/log4shelldetect/log4shelldetect-0.0.4.ebuild')
-rw-r--r--dev-util/log4shelldetect/log4shelldetect-0.0.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/log4shelldetect/log4shelldetect-0.0.4.ebuild b/dev-util/log4shelldetect/log4shelldetect-0.0.4.ebuild
new file mode 100644
index 000000000000..faca4fb5bf77
--- /dev/null
+++ b/dev-util/log4shelldetect/log4shelldetect-0.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="check for java programs vulnerable to log4shell"
+HOMEPAGE="https://github.com/1lann/log4shelldetect"
+
+EGO_SUM=(
+ "github.com/fatih/color v1.13.0"
+ "github.com/fatih/color v1.13.0/go.mod"
+ "github.com/karrick/godirwalk v1.16.1"
+ "github.com/karrick/godirwalk v1.16.1/go.mod"
+ "github.com/mattn/go-colorable v0.1.9"
+ "github.com/mattn/go-colorable v0.1.9/go.mod"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-isatty v0.0.14"
+ "github.com/mattn/go-isatty v0.0.14/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200223170610-d5e6a3e2c0ae/go.mod"
+ "golang.org/x/sys v0.0.0-20210630005230-0f9fa26af87c"
+ "golang.org/x/sys v0.0.0-20210630005230-0f9fa26af87c/go.mod"
+ )
+go-module_set_globals
+SRC_URI="https://github.com/1lann/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ go build . || die
+}
+
+src_install() {
+dobin log4shelldetect
+dodoc README.md
+}