summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-03-30 22:56:13 +0800
committerYixun Lan <dlan@gentoo.org>2021-03-30 23:11:37 +0800
commitc7d67d46add60fadacb3c43e40358c3762c135bb (patch)
treeac9b9b5661b08e789412c79a1f981687ad334dca /dev-util/lttng-modules/lttng-modules-2.11.8.ebuild
parentdev-ros/openslam_gmapping: update license (diff)
downloadgentoo-c7d67d46add60fadacb3c43e40358c3762c135bb.tar.gz
gentoo-c7d67d46add60fadacb3c43e40358c3762c135bb.tar.bz2
gentoo-c7d67d46add60fadacb3c43e40358c3762c135bb.zip
dev-util/lttng-modules: version bump 2.12.5, 2.11.8
Closes: https://bugs.gentoo.org/778740 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/lttng-modules/lttng-modules-2.11.8.ebuild')
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.11.8.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/lttng-modules-2.11.8.ebuild b/dev-util/lttng-modules/lttng-modules-2.11.8.ebuild
new file mode 100644
index 000000000000..6431bfccfccc
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.11.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 27; then
+ eerror "${PN} require Linux kernel >= 2.6.27"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md TODO
+}