summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-08-25 19:27:13 +0200
committerMichael Weber <xmw@gentoo.org>2018-08-25 19:37:56 +0200
commit0adfc6b25db8ac2b521f988e2db4004bd212b1ca (patch)
tree38c95bee5017a8a3831f2a35e42f958f572849bb /dev-util/lttng-tools/lttng-tools-2.10.5.ebuild
parentdev-util/lttng-ust: Version bump. (diff)
downloadgentoo-0adfc6b25db8ac2b521f988e2db4004bd212b1ca.tar.gz
gentoo-0adfc6b25db8ac2b521f988e2db4004bd212b1ca.tar.bz2
gentoo-0adfc6b25db8ac2b521f988e2db4004bd212b1ca.zip
dev-util/lttng-tools: Version bump
- Fix docdir to ${PF} - Fix USE=ust unkown configure option Closes: https://bugs.gentoo.org/663826 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'dev-util/lttng-tools/lttng-tools-2.10.5.ebuild')
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.10.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/lttng-tools/lttng-tools-2.10.5.ebuild b/dev-util/lttng-tools/lttng-tools-2.10.5.ebuild
new file mode 100644
index 000000000000..d42ffde22d8b
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.10.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( dev-util/lttng-ust:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is -lt 2 6 27; then
+ ewarn "${PN} require Linux kernel >= 2.6.27"
+ ewarn " pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
+ ewarn " the session daemon. There were introduce in the 2.6.27"
+ fi
+}
+
+src_configure() {
+ econf \
+ $(usex ust "" --without-lttng-ust) \
+ --docdir=/usr/share/doc/${PF}
+}