summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-07 21:59:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:40 +0100
commitd6f36681e844c8e31b8ed51768e83390646278f9 (patch)
tree3c0ee4e52c685ead549366bfc073f6890ed5c148 /dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
parentdev-libs/libqtxdg: version bump to 3.3.1 (diff)
downloadgentoo-d6f36681e844c8e31b8ed51768e83390646278f9.tar.gz
gentoo-d6f36681e844c8e31b8ed51768e83390646278f9.tar.bz2
gentoo-d6f36681e844c8e31b8ed51768e83390646278f9.zip
dev-util/lxqt-build-tools: version bump to 0.6.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild')
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
new file mode 100644
index 000000000000..3093a7f96f25
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"