summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-04-18 21:32:45 +0300
committerSam James <sam@gentoo.org>2022-05-15 00:11:55 +0000
commitdb538ec6b175cdf7e5f4594e0a943c6d6de9a80e (patch)
tree92adfadde5d9765e53c569dae382c940acc9107e /dev-util/lxqt-build-tools
parentx11-misc/obconf-qt: add version 0.16.2 (diff)
downloadgentoo-db538ec6b175cdf7e5f4594e0a943c6d6de9a80e.tar.gz
gentoo-db538ec6b175cdf7e5f4594e0a943c6d6de9a80e.tar.bz2
gentoo-db538ec6b175cdf7e5f4594e0a943c6d6de9a80e.zip
dev-util/lxqt-build-tools: add version 0.11.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest1
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.11.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index ce04c480fecd..abebc93b5666 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-build-tools-0.10.0.tar.xz 25312 BLAKE2B 7ba08ee181353454264685f6ec7407cd4858acd55674213a5f2bab123b400e6caae0eb5e803ca4d0dc30b19ca069c0659c4531ac64ee017fcd619560e09195fd SHA512 ee7282344c6fbf09d85f845c60075b6c343ce6b6f8c233c7d664faff3b570e2836192aa2233b951242b66d86254971011d4d0bc225811344829fdc5bc83b0e5f
+DIST lxqt-build-tools-0.11.0.tar.xz 25348 BLAKE2B cf342baf8454ea91dfd7a5206b9c1d02737fa5434e8dfdc681218bcc22bd8d7a47fc85acd3d0f54fd75113a32e4440af23f8536e3a87e0051daccfc026e9eef5 SHA512 d421aaf74b13efa3b603b5c8a998bfd6091f5d3c45e0201d64e0c1f12d93c45fdc12d9232b0ac1c98ccf47007560c5814612162d1ac879bb3173bad57164408d
DIST lxqt-build-tools-0.9.0.tar.xz 25296 BLAKE2B 9686a445c75a700a38150b4493f6c019ba0782e219b3482f67c6a324f35ffe252fddc614daefbd8616ee16ef8bc331c7e4302ddf2df870d1c3696a80cfb585a8 SHA512 9a464393ea6d871c5856ebf5b8fa3d31a89c6419ac084e7146aed675f2b20a139bb3eedde017d6ca03167ee6e30a37a62239ab4e8b76f5b6db244d26ab164892
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.11.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.11.0.ebuild
new file mode 100644
index 000000000000..27cb7786d55f
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.11.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"