summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-30 18:04:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-31 23:40:11 +0100
commitbbfb176d2d634bfd8747e014b8006d2fd0e98b4a (patch)
tree49bcbaac68076b19e5a89e765668186a46bf54ab /dev-util/mdds/files
parentnet-libs/aqbanking: 6.2.5 version bump (diff)
downloadgentoo-bbfb176d2d634bfd8747e014b8006d2fd0e98b4a.tar.gz
gentoo-bbfb176d2d634bfd8747e014b8006d2fd0e98b4a.tar.bz2
gentoo-bbfb176d2d634bfd8747e014b8006d2fd0e98b4a.zip
dev-util/mdds: 1.7.0 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds/files')
-rw-r--r--dev-util/mdds/files/mdds-1.7.0-bashism.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/mdds/files/mdds-1.7.0-bashism.patch b/dev-util/mdds/files/mdds-1.7.0-bashism.patch
new file mode 100644
index 000000000000..3e94f32e8f8b
--- /dev/null
+++ b/dev-util/mdds/files/mdds-1.7.0-bashism.patch
@@ -0,0 +1,75 @@
+From 65da7c25f4d8204b1379a0afb46d82dc1b263ab0 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 28 May 2020 18:36:07 +0200
+Subject: [PATCH] Fix bashisms in configure.ac
+
+---
+ configure.ac | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 00ab937..2282165 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,7 +32,7 @@ AC_ARG_ENABLE(debug-stdcxx,
+ ]
+ ,debug_stdcxx=yes)
+
+-AS_IF([test x"$debug_stdcxx" == "xyes"], [
++AS_IF([test x"$debug_stdcxx" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -D_GLIBCXX_DEBUG"
+ ])
+
+@@ -42,7 +42,7 @@ AC_ARG_ENABLE(release-tests,
+ ]
+ ,release_tests=yes)
+
+-AS_IF([test x"$release_tests" == "xyes"], [
++AS_IF([test x"$release_tests" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -DNDEBUG -O2"
+ ])
+
+@@ -56,11 +56,11 @@ AC_ARG_ENABLE(loop-unrolling,
+ [enable_loop_unrolling="$enableval"],[enable_loop_unrolling=yes]
+ )
+
+-AS_IF([test x"$enable_loop_unrolling" == "xno"], [
++AS_IF([test x"$enable_loop_unrolling" = "xno"], [
+ CXXFLAGS="$CXXFLAGS -DMDDS_LOOP_UNROLLING=0"
+ ])
+
+-AS_IF([test x"$enable_gcov" == "xyes"], [
++AS_IF([test x"$enable_gcov" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS --coverage -O0"
+ ])
+
+@@ -69,7 +69,7 @@ AC_ARG_ENABLE(openmp,
+ [enable_openmp="$enableval"],[enable_openmp=yes]
+ )
+
+-AS_IF([test x"$enable_openmp" == "xyes"], [
++AS_IF([test x"$enable_openmp" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -fopenmp -DMDDS_USE_OPENMP=1"
+ LDFLAGS="$LDFLAGS -fopenmp"
+ ])
+@@ -79,7 +79,7 @@ AC_ARG_ENABLE(sanitizer-coverage,
+ [enable_sanitizer_coverage="$enableval"],[enable_sanitizer_coverage=no]
+ )
+
+-AS_IF([test x"$enable_sanitizer_coverage" == "xyes"], [
++AS_IF([test x"$enable_sanitizer_coverage" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -fprofile-instr-generate -fcoverage-mapping -O0"
+ ])
+
+@@ -122,7 +122,7 @@ AC_ARG_ENABLE([werror],
+ [enable_werror="$enableval"],
+ [enable_werror=no]
+ )
+-AS_IF([test x"$enable_werror" == "xyes"], [
++AS_IF([test x"$enable_werror" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -Werror"
+ ])
+
+--
+2.26.2
+