summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-04-22 19:35:11 +0300
committerMart Raudsepp <leio@gentoo.org>2020-04-22 19:35:51 +0300
commit5dada79038b992c07cfe863d515ff17479dc6d3a (patch)
treeed3081cbc41ebedd161339b4968779e4f338d537 /dev-util/meld/meld-3.20.2-r1.ebuild
parentgnome-extra/evolution-data-server: Drop dependency on python (diff)
downloadgentoo-5dada79038b992c07cfe863d515ff17479dc6d3a.tar.gz
gentoo-5dada79038b992c07cfe863d515ff17479dc6d3a.tar.bz2
gentoo-5dada79038b992c07cfe863d515ff17479dc6d3a.zip
dev-util/meld: workaround problems with --skip-build
Fixes regression since eclass commit 180fa85d7d00aea463c399f70348beaad9166eb7 Closes: https://bugs.gentoo.org/718014 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/meld/meld-3.20.2-r1.ebuild')
-rw-r--r--dev-util/meld/meld-3.20.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/meld/meld-3.20.2-r1.ebuild b/dev-util/meld/meld-3.20.2-r1.ebuild
new file mode 100644
index 000000000000..cd83e457a06a
--- /dev/null
+++ b/dev-util/meld/meld-3.20.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.20:3[introspection]
+ >=x11-libs/gtksourceview-3.20.0:3.0[introspection]
+ >=x11-libs/pango-1.34[introspection]
+ x11-themes/hicolor-icon-theme
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+"
+# dev-python/distro is soft-required in BDEPEND for python3.8 and onwards,
+# but it's mainly needed for debian and derivatives - seems the fallback
+# works fine, as we aren't a special_case, just an annoying warning.
+
+python_compile_all() {
+ mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
+}
+
+python_install() {
+ local mydistutilsargs=( --no-update-icon-cache --no-compile-schemas build )
+ distutils-r1_python_install
+ rm "${ED}"/usr/share/doc/meld-${PV}/{COPYING,NEWS} || die
+ rmdir "${ED}"/usr/share/doc/meld-${PV} || die
+}