summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-09-18 01:02:36 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-09-18 01:05:12 +0300
commit9a895f193b49d4c0221873d81252ceef4d3e8d13 (patch)
tree0122881f25baaac584ecbe605d89fca2b7fc0f87 /dev-util/mingw64-runtime
parentprofiles: QA mask media-libs/fontconfig-2.13.1. (diff)
downloadgentoo-9a895f193b49d4c0221873d81252ceef4d3e8d13.tar.gz
gentoo-9a895f193b49d4c0221873d81252ceef4d3e8d13.tar.bz2
gentoo-9a895f193b49d4c0221873d81252ceef4d3e8d13.zip
dev-util/mingw64-runtime: verison bump
for some reason console application is not working on my windows machine, more testing need to be done, removed keywords. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/Manifest1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-6.0.0.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-util/mingw64-runtime/Manifest b/dev-util/mingw64-runtime/Manifest
index 04400d162ef5..f589f7a41b38 100644
--- a/dev-util/mingw64-runtime/Manifest
+++ b/dev-util/mingw64-runtime/Manifest
@@ -8,3 +8,4 @@ DIST mingw-w64-v5.0.1.tar.bz2 9160780 BLAKE2B 52964e7ae113d8886648cb0395514067fa
DIST mingw-w64-v5.0.2.tar.bz2 9107077 BLAKE2B b8e3e614fe4a1ea6a4770efdd029300e923e3b7b39b71731692281da44f468b235d487d38d7e1b4396e1b44a4c60fcc7a67a6c1331fb46e339c13c86bf7de7bd SHA512 430065a822afb9901219b1f86ea221ae70ef7820ea298f51828bf1689a014115dade967a806388b7ee3ed1ea1d6c53970514ec64d0185b5024523093d9e96060
DIST mingw-w64-v5.0.3.tar.bz2 9160627 BLAKE2B 941b40c426548564e8b2da0af8e917dad34bdbf0b05c63ea2127e39139bcce5d86e80433817483c64cd2a6ef6140a7818a76564ff5d9408614ecaa58f17b41e7 SHA512 85bc0244cd30ef38262792d61502a012348b8220ef249352b68ddfa40663ca1cae5f81bed70caa9579469fad6ad16a95f02387c280effeda7ce8287b549f3fc9
DIST mingw-w64-v5.0.4.tar.bz2 9163093 BLAKE2B fd039995c73690c12ddf1612d42edefbb572386b2ca8508fd5a5edd9e715ced41c05c62efec8eda07b9ec7a1e9e658bf3b3dedeb18695a076b5bc2067e86d68d SHA512 5b279222e86475a982e2aeb9fc14853f4fac0ca0c5a2d56f303584d1b348726afd99b0292a5ed050d326e7cb1434e5ad5b5dfdfb37c73fd08f13e7f4f4bcc046
+DIST mingw-w64-v6.0.0.tar.bz2 9045653 BLAKE2B 8a54dca2d06c92ab968a93240996d07ab3b1ed4652555a48b7581c477856d5784ed192c578d78186e171e400bd18b4de3c6cafbdd96109367ad13c37792015c1 SHA512 e3d3663e0cb33a16f90b1a33e81b5a30d26f7e34270b14e865c10068f2a2d32da9ef8cbbb0c3fed9c71429ae11c82152ff3b87d81558929b2a4993dc99cfc11e
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-6.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-6.0.0.ebuild
new file mode 100644
index 000000000000..47cd6c8a3d10
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-6.0.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="headers-only idl libraries tools"
+RESTRICT="strip"
+
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use headers-only
+}
+alt_prefix() {
+ is_crosscompile && echo /usr/${CTARGET}
+}
+crt_with() {
+ just_headers && echo --without-$1 || echo --with-$1
+}
+crt_use_enable() {
+ just_headers && echo --without-$2 || use_enable "$@"
+}
+crt_use_with() {
+ just_headers && echo --without-$2 || use_with "$@"
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_configure() {
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ if ! just_headers; then
+ mkdir "${WORKDIR}/headers"
+ pushd "${WORKDIR}/headers" > /dev/null
+ CHOST=${CTARGET} "${S}/configure" \
+ --prefix="${T}/tmproot" \
+ --with-headers \
+ --without-crt \
+ || die
+ popd > /dev/null
+ append-cppflags "-I${T}/tmproot/include"
+ fi
+
+ # By default configure tries to set --sysroot=${prefix}. We disable
+ # this behaviour with --with-sysroot=no to use gcc's sysroot default.
+ # That way we can cross-build mingw64-runtime with cross-emerge.
+ CHOST=${CTARGET} econf \
+ --with-sysroot=no \
+ --prefix="${EPREFIX}"$(alt_prefix)/usr \
+ --with-headers \
+ --enable-sdk \
+ $(crt_with crt) \
+ $(crt_use_enable idl idl) \
+ $(crt_use_with libraries libraries) \
+ $(crt_use_with tools tools) \
+ $(
+ $(tc-getCPP ${CTARGET}) ${CPPFLAGS} -dM - < /dev/null | grep -q __MINGW64__ \
+ && echo --disable-lib32 --enable-lib64 \
+ || echo --enable-lib32 --disable-lib64
+ )
+}
+
+src_compile() {
+ if ! just_headers; then
+ emake -C "${WORKDIR}/headers" install
+ fi
+ default
+}
+
+src_install() {
+ default
+
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${ED}/usr/share"
+}