summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-12 16:43:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-12 16:43:34 +0000
commitbde530ac386dd4b1b8c6154d5fdd717da5ba4566 (patch)
treee14b7366dabb5a2ca4ed4c8046395fd3046bfa5b /dev-util/mingw64-runtime
parentdev-util/mingw64-runtime: bump up to 7.0.0 (diff)
downloadgentoo-bde530ac386dd4b1b8c6154d5fdd717da5ba4566.tar.gz
gentoo-bde530ac386dd4b1b8c6154d5fdd717da5ba4566.tar.bz2
gentoo-bde530ac386dd4b1b8c6154d5fdd717da5ba4566.zip
dev-util/mingw64-runtime: drop old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/Manifest1
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-5.0.4.ebuild107
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r1.ebuild112
3 files changed, 0 insertions, 220 deletions
diff --git a/dev-util/mingw64-runtime/Manifest b/dev-util/mingw64-runtime/Manifest
index 5a4b7418b8ce..2769e87b5d4c 100644
--- a/dev-util/mingw64-runtime/Manifest
+++ b/dev-util/mingw64-runtime/Manifest
@@ -1,3 +1,2 @@
-DIST mingw-w64-v5.0.4.tar.bz2 9163093 BLAKE2B fd039995c73690c12ddf1612d42edefbb572386b2ca8508fd5a5edd9e715ced41c05c62efec8eda07b9ec7a1e9e658bf3b3dedeb18695a076b5bc2067e86d68d SHA512 5b279222e86475a982e2aeb9fc14853f4fac0ca0c5a2d56f303584d1b348726afd99b0292a5ed050d326e7cb1434e5ad5b5dfdfb37c73fd08f13e7f4f4bcc046
DIST mingw-w64-v6.0.0.tar.bz2 9045653 BLAKE2B 8a54dca2d06c92ab968a93240996d07ab3b1ed4652555a48b7581c477856d5784ed192c578d78186e171e400bd18b4de3c6cafbdd96109367ad13c37792015c1 SHA512 e3d3663e0cb33a16f90b1a33e81b5a30d26f7e34270b14e865c10068f2a2d32da9ef8cbbb0c3fed9c71429ae11c82152ff3b87d81558929b2a4993dc99cfc11e
DIST mingw-w64-v7.0.0.tar.bz2 9071231 BLAKE2B da00794ec456ede5913a565248c79255407c058469cb7338cf81b8d03c1e39f4189016b01734b786c0ad8f18166a24fdb95ca72edc954f31151e5d3aa2b2a899 SHA512 30e5b2824a24eeb99ab519e3fc134cc9a7f04ee8b853bc8d66a13d1ab74144bf78b93e162bfe6de2a5e61f63c0e620a933b260b02d019cd68cc4b78bd36c67fd
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-5.0.4.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-5.0.4.ebuild
deleted file mode 100644
index 93965bb06d7c..000000000000
--- a/dev-util/mingw64-runtime/mingw64-runtime-5.0.4.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-WANT_AUTOMAKE="1.15"
-
-inherit autotools flag-o-matic eutils
-
-DESCRIPTION="Free Win64 runtime and import library definitions"
-HOMEPAGE="http://mingw-w64.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="headers-only idl libraries tools"
-RESTRICT="strip"
-
-S="${WORKDIR}/mingw-w64-v${PV}"
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-just_headers() {
- use headers-only
-}
-alt_prefix() {
- is_crosscompile && echo /usr/${CTARGET}
-}
-crt_with() {
- just_headers && echo --without-$1 || echo --with-$1
-}
-crt_use_enable() {
- just_headers && echo --without-$2 || use_enable "$@"
-}
-crt_use_with() {
- just_headers && echo --without-$2 || use_with "$@"
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration"
- fi
-}
-
-src_configure() {
- CHOST=${CTARGET} strip-unsupported-flags
-
- if ! just_headers; then
- mkdir "${WORKDIR}/headers"
- pushd "${WORKDIR}/headers" > /dev/null
- CHOST=${CTARGET} "${S}/configure" \
- --prefix="${T}/tmproot" \
- --with-headers \
- --without-crt \
- || die
- popd > /dev/null
- append-cppflags "-I${T}/tmproot/include"
- fi
-
- # By default configure tries to set --sysroot=${prefix}. We disable
- # this behaviour with --with-sysroot=no to use gcc's sysroot default.
- # That way we can cross-build mingw64-runtime with cross-emerge.
- CHOST=${CTARGET} econf \
- --with-sysroot=no \
- --prefix="${EPREFIX}"$(alt_prefix)/usr \
- --with-headers \
- --enable-sdk \
- $(crt_with crt) \
- $(crt_use_enable idl idl) \
- $(crt_use_with libraries libraries) \
- $(crt_use_with tools tools) \
- $(
- $(tc-getCPP ${CTARGET}) ${CPPFLAGS} -dM - < /dev/null | grep -q __MINGW64__ \
- && echo --disable-lib32 --enable-lib64 \
- || echo --enable-lib32 --disable-lib64
- )
-}
-
-src_compile() {
- if ! just_headers; then
- emake -C "${WORKDIR}/headers" install
- fi
- default
-}
-
-src_install() {
- default
-
- if is_crosscompile ; then
- # gcc is configured to look at specific hard-coded paths for mingw #419601
- dosym usr /usr/${CTARGET}/mingw
- dosym usr /usr/${CTARGET}/${CTARGET}
- dosym usr/include /usr/${CTARGET}/sys-include
- fi
-
- rm -rf "${ED}/usr/share"
-}
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r1.ebuild
deleted file mode 100644
index dbf9db4e858c..000000000000
--- a/dev-util/mingw64-runtime/mingw64-runtime-6.0.0-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-inherit autotools flag-o-matic eutils
-
-DESCRIPTION="Free Win64 runtime and import library definitions"
-HOMEPAGE="http://mingw-w64.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# USE=libraries needs working stage2 compiler: bug #665512
-IUSE="headers-only idl libraries tools"
-RESTRICT="strip"
-
-S="${WORKDIR}/mingw-w64-v${PV}"
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-just_headers() {
- use headers-only
-}
-alt_prefix() {
- is_crosscompile && echo /usr/${CTARGET}
-}
-crt_with() {
- just_headers && echo --without-$1 || echo --with-$1
-}
-crt_use_enable() {
- just_headers && echo --without-$2 || use_enable "$@"
-}
-crt_use_with() {
- just_headers && echo --without-$2 || use_with "$@"
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration"
- fi
-}
-
-src_configure() {
- CHOST=${CTARGET} strip-unsupported-flags
- # Normally mingw-64 does not use dynamic linker.
- # But at configure time it uses $LDFLAGS.
- # When default -Wl,--hash-style=gnu is passed
- # __CTORS_LIST__ / __DTORS_LIST__ is mis-detected
- # for target ld and binaries crash at shutdown.
- filter-ldflags '-Wl,--hash-style=*'
-
- if ! just_headers; then
- mkdir "${WORKDIR}/headers"
- pushd "${WORKDIR}/headers" > /dev/null
- CHOST=${CTARGET} "${S}/configure" \
- --prefix="${T}/tmproot" \
- --with-headers \
- --without-crt \
- || die
- popd > /dev/null
- append-cppflags "-I${T}/tmproot/include"
- fi
-
- # By default configure tries to set --sysroot=${prefix}. We disable
- # this behaviour with --with-sysroot=no to use gcc's sysroot default.
- # That way we can cross-build mingw64-runtime with cross-emerge.
- CHOST=${CTARGET} econf \
- --with-sysroot=no \
- --prefix="${EPREFIX}"$(alt_prefix)/usr \
- --with-headers \
- --enable-sdk \
- $(crt_with crt) \
- $(crt_use_enable idl idl) \
- $(crt_use_with libraries libraries) \
- $(crt_use_with tools tools) \
- $(
- $(tc-getCPP ${CTARGET}) ${CPPFLAGS} -dM - < /dev/null | grep -q __MINGW64__ \
- && echo --disable-lib32 --enable-lib64 \
- || echo --enable-lib32 --disable-lib64
- )
-}
-
-src_compile() {
- if ! just_headers; then
- emake -C "${WORKDIR}/headers" install
- fi
- default
-}
-
-src_install() {
- default
-
- if is_crosscompile ; then
- # gcc is configured to look at specific hard-coded paths for mingw #419601
- dosym usr /usr/${CTARGET}/mingw
- dosym usr /usr/${CTARGET}/${CTARGET}
- dosym usr/include /usr/${CTARGET}/sys-include
- fi
-
- rm -rf "${ED}/usr/share"
-}