summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/molecule-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/molecule-plugins')
-rw-r--r--dev-util/molecule-plugins/Manifest1
-rw-r--r--dev-util/molecule-plugins/metadata.xml8
-rw-r--r--dev-util/molecule-plugins/molecule-plugins-1.0.2.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/molecule-plugins/Manifest b/dev-util/molecule-plugins/Manifest
new file mode 100644
index 000000000000..42fc84e168b4
--- /dev/null
+++ b/dev-util/molecule-plugins/Manifest
@@ -0,0 +1 @@
+DIST molecule-plugins-1.0.2.tar.bz2 17428 SHA256 1e2c8de1e4c8dd3b8623bb048527153bef147e15d01d13e61575711561703b4d SHA512 65b75c23f3c662812be2ab4fe0c92bd99aba48da6e05aad6175ba3fe1cd8106d9085ed53f27c738ef6af1b327ac8ac872ef7c3c48728366b510b7a82bb90c866 WHIRLPOOL 90f1f22c0e3514ac3ba658b9de32ca71eafa60ba7e5a6e212d0b1fbcbcd4cd22a6be405c9dad06179e1db9d09e161fb50cf57d3307b8a8a950fe6366e5e788b1
diff --git a/dev-util/molecule-plugins/metadata.xml b/dev-util/molecule-plugins/metadata.xml
new file mode 100644
index 000000000000..084e4ee0d117
--- /dev/null
+++ b/dev-util/molecule-plugins/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/molecule-plugins/molecule-plugins-1.0.2.ebuild b/dev-util/molecule-plugins/molecule-plugins-1.0.2.ebuild
new file mode 100644
index 000000000000..a68a9c387ae1
--- /dev/null
+++ b/dev-util/molecule-plugins/molecule-plugins-1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="A set fo base plugins for Molecule"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-util/molecule-core-1.0.1 !<dev-util/molecule-1"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}