summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/monodevelop-debugger-gdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/monodevelop-debugger-gdb')
-rw-r--r--dev-util/monodevelop-debugger-gdb/Manifest1
-rw-r--r--dev-util/monodevelop-debugger-gdb/metadata.xml5
-rw-r--r--dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-3.0.2.ebuild34
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/monodevelop-debugger-gdb/Manifest b/dev-util/monodevelop-debugger-gdb/Manifest
new file mode 100644
index 000000000000..b8f00aa3df6f
--- /dev/null
+++ b/dev-util/monodevelop-debugger-gdb/Manifest
@@ -0,0 +1 @@
+DIST monodevelop-debugger-gdb-3.0.2.tar.bz2 16301 SHA256 e4b37adbbaa56775f35c34e5fd89876879671c82b92691119d9a57b47a229aec SHA512 b6141472a746678083c45401aa171011e1e325b46acd6f50675be22e447cbe4d7a1fb904920495f2e3b73404cb759fe82de0deeaeceaf70d9baf7850e9e66a85 WHIRLPOOL c071c641b2147fe7ce2e02f46620999f833c4b008ac6374a8278e451ed6e586750f345573fa777e7ca246591cf67d83d8c120ce9c1ba5acd16b3b9509e3b1b88
diff --git a/dev-util/monodevelop-debugger-gdb/metadata.xml b/dev-util/monodevelop-debugger-gdb/metadata.xml
new file mode 100644
index 000000000000..d35e9300c540
--- /dev/null
+++ b/dev-util/monodevelop-debugger-gdb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-3.0.2.ebuild b/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-3.0.2.ebuild
new file mode 100644
index 000000000000..019c636413ee
--- /dev/null
+++ b/dev-util/monodevelop-debugger-gdb/monodevelop-debugger-gdb-3.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit mono multilib versionator
+
+DESCRIPTION="GDB Extension for MonoDevelop"
+HOMEPAGE="http://www.monodevelop.com/"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/mono-2.4
+ =dev-util/monodevelop-$(get_version_component_range 1-2)*
+ sys-devel/gdb"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ ./configure --prefix=/usr
+}
+
+src_install() {
+ default
+ mono_multilib_comply
+}