summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-14 10:08:48 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-05 22:17:00 +0200
commit85f00aa1698d24bef393b6dfeb3c5a5c8b1a26d9 (patch)
tree8fd17a90c934cdd18cb6ae721712d404c5095f8d /dev-util/omake/omake-0.10.2.ebuild
parentdev-ml/ocamlnet: Replace STRIP_MASK with RESTRICT=strip (diff)
downloadgentoo-85f00aa1698d24bef393b6dfeb3c5a5c8b1a26d9.tar.gz
gentoo-85f00aa1698d24bef393b6dfeb3c5a5c8b1a26d9.tar.bz2
gentoo-85f00aa1698d24bef393b6dfeb3c5a5c8b1a26d9.zip
dev-util/omake: Replace STRIP_MASK with RESTRICT=strip
Closes: https://bugs.gentoo.org/651452 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/omake/omake-0.10.2.ebuild')
-rw-r--r--dev-util/omake/omake-0.10.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/omake/omake-0.10.2.ebuild b/dev-util/omake/omake-0.10.2.ebuild
index 46e34cdb6a51..d8f2abbc56cc 100644
--- a/dev-util/omake/omake-0.10.2.ebuild
+++ b/dev-util/omake/omake-0.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,8 @@ DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
readline? ( >=sys-libs/readline-4.3:0= )"
RDEPEND="${DEPEND}"
+RESTRICT="!ocamlopt? ( strip )"
+
src_prepare() {
epatch \
"${FILESDIR}/${P}-cflags.patch"
@@ -45,5 +47,4 @@ src_install() {
dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt
dohtml -r doc/html/*
fi
- use ocamlopt || export STRIP_MASK="*/bin/*"
}