summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-07-10 06:32:26 -0400
committerMichał Górny <mgorny@gentoo.org>2019-07-18 09:13:51 +0200
commitcaf317d365dca044a65536687be48c980d47df6c (patch)
tree810a25d3e2ab3d3a17a18d5c992dca310a14d3d6 /dev-util/packer/packer-1.4.1.ebuild
parentmedia-fonts/fira-code: add 1.207 (diff)
downloadgentoo-caf317d365dca044a65536687be48c980d47df6c.tar.gz
gentoo-caf317d365dca044a65536687be48c980d47df6c.tar.bz2
gentoo-caf317d365dca044a65536687be48c980d47df6c.zip
dev-util/packer: version bump to 1.4.1
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Dan Molik <dan@danmolik.com> Tested-by: Dan Molik <dan@danmolik.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/packer/packer-1.4.1.ebuild')
-rw-r--r--dev-util/packer/packer-1.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.4.1.ebuild b/dev-util/packer/packer-1.4.1.ebuild
new file mode 100644
index 000000000000..f0bba724a79d
--- /dev/null
+++ b/dev-util/packer/packer-1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+
+EGO_PN="github.com/hashicorp/packer"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.12.0"
+
+DOCS=( src/${EGO_PN}/{README,CHANGELOG}.md )
+
+src_compile() {
+ cd "src/${EGO_PN}" || die
+ GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+ -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+ dobin packer
+
+ einstalldocs
+
+ pushd "src/${EGO_PN}" || die
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+ popd || die
+}