summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-21 17:10:14 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-21 17:10:14 -0500
commit265807bebfb2e1bbd05fc82d0afd47a016808bc3 (patch)
treed30e3f4efc634c86a635dc8d4f2252dcbb868bf5 /dev-util/packer/packer-1.4.4.ebuild
parentapp-admin/terraform: 0.12.24 general cleanups (diff)
downloadgentoo-265807bebfb2e1bbd05fc82d0afd47a016808bc3.tar.gz
gentoo-265807bebfb2e1bbd05fc82d0afd47a016808bc3.tar.bz2
gentoo-265807bebfb2e1bbd05fc82d0afd47a016808bc3.zip
dev-util/packer: 1.4.4 drop use of golang-base
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/packer/packer-1.4.4.ebuild')
-rw-r--r--dev-util/packer/packer-1.4.4.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-util/packer/packer-1.4.4.ebuild b/dev-util/packer/packer-1.4.4.ebuild
index a361a43a1fa3..ab0e1cbcd571 100644
--- a/dev-util/packer/packer-1.4.4.ebuild
+++ b/dev-util/packer/packer-1.4.4.ebuild
@@ -3,25 +3,21 @@
EAPI=7
-inherit golang-base go-module
+inherit go-module
DESCRIPTION="A tool to create identical machine images for multiple platforms"
HOMEPAGE="https://www.packer.io"
-
-EGO_PN="github.com/hashicorp/packer"
SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 icu imagemagick ISC JSON MIT MPL-2.0"
-
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
DOCS=( {README,CHANGELOG}.md )
src_compile() {
- GOCACHE="${T}/go-cache" go build \
+ go build \
+ -mod=vendor \
-work -o "bin/${PN}" ./ || die
}